Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

xsi not exporting right...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • xsi not exporting right...

    when I try to apply a material to a static mesh exported from xsi it doesn't get the texture, just the main color of the texture

  • #2
    Originally posted by robin1232 View Post
    when I try to apply a material to a static mesh exported from xsi it doesn't get the texture, just the main color of the texture
    Post the screenshot - what could be the main color if 256x256 texture has 65000 main color values?

    My blind guess is
    1) Invalid UVs - did you apply texture projection to this mesh in SI?
    2) Invalid UV index in static mesh editor.
    3) Invalid material - color expression plugged into diffuse channel etc.

    Comment


    • #3
      Originally posted by mslaf View Post
      Post the screenshot - what could be the main color if 256x256 texture has 65000 main color values?

      My blind guess is
      1) Invalid UVs - did you apply texture projection to this mesh in SI?
      how do I do that?
      also, the material did work right on some stock models

      Comment


      • #4
        Originally posted by robin1232 View Post
        how do I do that?
        also, the material did work right on some stock models
        Create a texture projection - using 'property->texture projection->" and projection that fits your mesh shape. Then go to texture editor (alt+7) and play with the UV's. Detailed description, really goes beyond this forum - especially that it's not a 'piece of cake' type process, so my advice it to search for some tutorials, like those for example.

        Comment


        • #5
          thanks, its working now.
          quite easy to do, but quite hard to figure out

          Comment

          Working...
          X