Announcement

Collapse
No announcement yet.

Horrible, horrible static mesh shading problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Horrible, horrible static mesh shading problem

    Hey guys. Been experimenting with importing static meshes into the engine and I came across a very annoying problem.

    Here's my model:

    All nice and theoreticaly clean.

    Now here's my model after exporting to UDK:


    Why doesn't it have the nice shading all the other UDK models get?

    #2
    check the mesh in 3dsmax and see if every triangle has the proper smoothing groups set up. If there are none set up, then unreal will assign 1 to the whole mesh.

    Comment


      #3
      And don't forget that UDK automatically converts all polys to triangles

      Comment


        #4
        First of all, I'm using XSI. Sorry for the misunderstanding.

        AFAIK, XSI hasn't got stuff like 'different smoothing groups'. There's geometry approximation and stuff but we don't really assign different smoothing groups there. So no idea what to do here.

        As for converting to triangles - that doesn't really help me. I tried triangulating in XSI and then exporting but I get the same problem.

        Edit:
        Here's another example. A model made by me, complete with normal, diffuse and specular maps:


        What is causing this weird shading?

        Comment


          #5
          I have never used XSI but I could not believe it wouldn't have smoothing groups. A google search found this:

          If it were mine and the environment it was going in wasn't to heavy. I would make it all qauds and sub-divide and move on. Your object is very low-poly.

          Comment


            #6
            IT IS SUPPOSED TO BE LOW POLY. It's a freaking cuboid. It's the simplest thing after a cube.

            Seriously, on another forum, another dude told me to go super-high-poly.

            Here's one of the sample UDK models, courtesy of Epic Games:


            See? It's lowpoly and has correct lighting. No need for 2000+ polys after subdividing.

            So please, can someone come up with any other method than "subdivide it until there's so many polys you can't notice the lighting problem"?

            :-/

            Sorry, I'm a bit on the edge after two people pointed out something that seems so 'hilarious' to me

            Comment


              #7
              Did you try to apply a material with a normal map and see if the problem still persists? Looks like ordinary vertex shadowing to me.....

              Comment


                #8
                A model made by me, complete with normal, diffuse and specular maps
                As you see, yes, I did. It was the first thing that came to my mind. Unfortunately, even a baked normal map doesn't solve the issue.

                Comment


                  #9
                  i'd recomend you switch to max, maya or blender for free. they recieve a lot more love than most other programs, and give better control over models in general.

                  the problem seems to be as already stated smooth groups. i would think u3 is treating your flat surface as a "soft" surface rather than a rigid one, resulting in undesiered shading issues (looks like its shadows). try importing to blender, selecting the faces that are you flat plane and setting the group to solid. then again, if xsi doesn't allow you to change the smooth groups you have litle other choice.

                  hope you sort it out, not sure if that work around will work but blender is pretty useful for those kinds of things. it can get messy so backup before anything

                  Comment


                    #10
                    Well the exporter is apparently working (if it wasn't, they wouldn't publish it) so I must be doing something wrong. There is no need to switch to other apps, that's just ridiculous XD

                    Comment


                      #11
                      Your problem has nothing to do with the smoothing groups, normal maps, materials or application you use.

                      By default all static meshes are illuminated using the vertex lighting (sometimes called as hardware lighting) - same like they were in the previous engine versions. It's the fastest shading method but also very imprecise.

                      You have to use lightmaps to get more precise shadows - see the tutorials how to setup and enable lightmaps on static meshes. Lightmaps require unique (in 0-1 image bounds) non-overlapping UV's and in most cases you will have to create additional texture projection using "Unique UV's" option from Property->Texture Projection menu.

                      Comment


                        #12
                        Heh, ****. Looks like the Lightmap Coordinate Index was set to 1 (which would be a custom lightmap UV if I'm correct) instead of 0 which is what I'd prefer - to use the actual model's UVs. So I set it to 0 and it fixed it

                        Now tell me one thing:
                        How safe is generating unique UVs for light maps using the tool in UDK? Is doing it by hand preferable? And why?

                        Comment


                          #13
                          Results vary, it can produce some pretty horrible stretching and split things up oddly. I tend to just use it as a stopgap until I can pester one of our modellers into doing a proper one, if it's obvious, and they forgot to do one in the first place.

                          Comment


                            #14
                            The main difference between doing it in SI and UED is that you have no editing option in UED. No way to fix it or adjust it and problems like invalid seams or incorrectly split UV islands are pretty common. I'm not sure about alignment/mirrors, that need to be horizontal to make the lightmaps cooperate correctly with the normal maps. In other words, you have very limited control over this function.

                            Comment


                              #15
                              Originally posted by Dandi8 View Post
                              IT IS SUPPOSED TO BE LOW POLY. It's a freaking cuboid. It's the simplest thing after a cube.

                              Seriously, on another forum, another dude told me to go super-high-poly.

                              Here's one of the sample UDK models, courtesy of Epic Games:


                              See? It's lowpoly and has correct lighting. No need for 2000+ polys after subdividing.

                              So please, can someone come up with any other method than "subdivide it until there's so many polys you can't notice the lighting problem"?

                              :-/

                              Sorry, I'm a bit on the edge after two people pointed out something that seems so 'hilarious' to me
                              Whatever, I'm sorry I tried to help and that I didn't instinctively know your box theme and I did offer another alternative.
                              Regardless, I am glad you figured it out but I will remain quite next time.

                              Comment

                              Working...
                              X