Announcement

Collapse
No announcement yet.

UCX_ Collision model ignored by vehicles?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UCX_ Collision model ignored by vehicles?

    We have created various static mesh's in blender and imported them into UDK with the same issue. We make the collision model using the UCX_ naming with an identical object in blender. The model appears to work very well for characters who attempt to walk on/in the model but for some reason any stock UDK vehicle ignores this and passes right through the mesh. How can we make the vehicle react to the collision model?

    Another question I have is mesh scale. Do we ideally want the mesh to be scaled to full game size in blender before exporting or is it ok to scale after import?

    Thanks!

    #2
    Originally posted by MephiticStudios View Post
    Another question I have is mesh scale. Do we ideally want the mesh to be scaled to full game size in blender before exporting or is it ok to scale after import?
    It may not be that big a deal but at some point your mesh will have to be scaled up for use either in the UDK editor or in Blender. I prefer in Blender because then it shows up nice in the UDK browser and it saves time later on cause I don't have to scale up again.

    I set the grid in Blender to 'spacing 1' 'divisions 8' and 'lines 64' so that it translates well into UDK. Before export I:
    Set the 'object center' to the grid and where the mesh will snap well in game. Then I [ctrl A] apply transformation and scaling to object data. Last I hit [n] for transform properties and scale up x, y and z by 32 or 64 or whatever I want a single Blender unit to become in UDK.

    Comment


      #3
      So I've played with every settings I can find regarding collision on both the mesh and the vehicle and they still pass right through them :-/ Does anyone have any idea's on this?

      Comment


        #4
        I've solved my own problem so I'll post a follow up in case anyone else has this same issue.

        I apparently didn't play with enough settings as all that was required was to uncheck the "Use simple rigid body collision checkbox" on the mesh in the content browser. I had this checked previously as a blender/udk tutorial indicated to turn off the other 2 options "Use simple box collision" and "Use simple line collision" but to leave the rigid body option on.

        I believe all three of these are on by default so remember to uncheck if you have included your collision model in your mesh via the UCX_ naming method.

        Comment

        Working...
        X