Announcement

Collapse
No announcement yet.

Strange normal problem,

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Owkey thanks, I solved it after numerous tries flipping the normals UDK finally seems to agree with me

    Leave a comment:


  • replied
    You could have an annoying problem that sometimes happens in Maya as well, but for Skeletal Meshes. You simply have to invert it in Blender, even though it looks wrong, and export it to Unreal. Could be some construction history or negative scaling issues on your mesh in Blender.

    Leave a comment:


  • replied
    Thanks alot, but for some reason the normals are fine inside Blender, could this be something that the exporter is messing up?

    Leave a comment:


  • replied
    Hey.

    Turn on backface culling in blender (its an option right? I havent used blender in a while and ive never had to mess much with normals...), that will show you your problem areas, though this time it seems to be the entire pipe but still, that will show you, make sure to check before you bring it into UDK.

    Eitherway just flip the normals in blender(reverse them I mean).

    The problem is that many of your normals directions are facing inwards and Unreal doesnt handle this well, even having doublesided materials doesnt appear to fix this.

    Originally posted by redfury112 View Post
    Hey,

    So I've imported some of my simple models to get a feel for the whole import process from Blender to UDK.

    Did a wall, some pilons and some piplelines. Now the first two went well everything turned up as expected.

    The pipeline however has its normals facing inwards, tho inside Blender the normals are fine. Any idea why this happens?


    Picture for reference:



    Thanks in advance,

    Leave a comment:


  • started a topic Strange normal problem,

    Strange normal problem,

    Hey,

    So I've imported some of my simple models to get a feel for the whole import process from Blender to UDK.

    Did a wall, some pilons and some piplelines. Now the first two went well everything turned up as expected.

    The pipeline however has its normals facing inwards, tho inside Blender the normals are fine. Any idea why this happens?


    Picture for reference:



    Thanks in advance,
Working...
X