Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Normalmap seams in Zmapper

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Normalmap seams in Zmapper

    Hi Guys,

    I trying to find a solution for a Zmapper/UDK Pipeline.

    The Situation: I did Character in 3dsmax, detail it in ZBrush and exporting normalmaps out of Zmapper. The normal map works fine within Zbrush as u can see below.



    But when i try to import the char and the normal map in UDK, i get this.




    As you can see i get seems at each UV Element. I spend several day now to figure out how to fix this, trying different settings in Zmapper. No success. I read several topics about this subject over at ZBruschcentral. None of the solutions worked in my case. Below you can see the UVLayout and the generated normal map out of Zmapper.



    I m pretty sure that this is a problem that a lot of people will have sooner or later. This really drives me nuts. I know there must be a solution for this. Mabe a different mapping method. Or maybe its just some setting in Zmapper that i dont tryed yet. Anyway, i'm out of ideas here,

    PLS HELP!

  • #2
    What software are you exporting the character's mesh from?

    Comment


    • #3
      3ds max 2010 and exported as obj with the zbrush default settings.

      Comment


      • #4
        I have a very quick test for you. If this doesn't work then there are other things to try but just do this first.

        Change the background color from white to rgb 128,128,255.

        Comment


        • #5
          Hey Kalle,

          I know what u mean but this doesnt help. zmapper has "seaming overpaint" on by default. otherwise i would probably see white lines at the seems.

          The problem is caused by how the UV's lay on the UV Grid and the way how the normal maps are rendered within ZBrush. So, red represent the x direction, green the y direction. If you take a look on the normal map u can see that, no matter how the UV's are layed, it has to run into problems.

          What i dont understand is when ZBrush uses the same UV Layout and it looked good why is it that Max and UDK have this seem problem.

          I also tryed different material ID's and put every UV Segment on a different UV Region so i can flip the red or green channel around within max, but that working neither.

          If i could just find a way in Zmapper to confom the different color information for the normal map.

          Comment


          • #6
            did you click fix seams in zbrush?

            Comment


            • #7
              I dont know what u mean. Within Zmapper there is no "Fix Seems" button.

              Comment


              • #8
                Not in zmapper but in tool bar in Texture palette.Once u create your Uv click fix seams.Are u using GUV or AUV?
                Also make sure you set zmapper too the right config for what your exporting it too.
                If in max set it too max best quality or if maya set it too Maya tangent space node best quality.I will pull out my trusty zbrush books for ya and have aextra read up on seams .

                Comment


                • #9
                  No, that doesnt seem to help either. I'm using UV Tiles made in Max btw.
                  Did your book says anything about the settings in Expert Pass 1 or 2? Hard to get any info on that topic. I m sure the solution is somewhere in those Expert pass settings.

                  Comment


                  • #10
                    will read up on this for you today.Im stuck looking after little one atm..
                    maybe try this in zbrush when exporting your obj make sure in prefrences Importexport iflip and eflip options are off.
                    Also under Tool menu click Export menu and make sure mrg is on and scale set to 1.
                    The book Im using too help is Scott Spencers character creation in zbrush..Its a worthy book matey if your getting into zbrush.Also Eric Keller has a awsome book called introducing zbrush..

                    Comment


                    • #11
                      What about baking maps in max rather than zbrush?

                      Comment


                      • #12
                        well, the flipped normal seems appears in max also, so that wouldnt really help i guess.

                        i discovered some flipped UV Elements and corrected them. that helped a little. but still, depending from wich angle your light falls you see the seems more or less. for example when the light falls direct from the point of view, the seems are less noticable. if it comes from another angle they appear more.

                        Comment


                        • #13
                          Have you tried just generating unique uv's (AUVs) within Zbrush for your high res mesh, exporting that high mesh with AUVs and then just letting xNormal have at it with your lower res mesh/ lower res mesh's uvs? It's one of the reasons xNormal is brilliant, let it sort it all out

                          Follow one of Epic's own here:
                          http://picasaweb.google.com/TheEnola...24297275475186

                          danimal

                          Comment


                          • #14
                            the tutorial u posted sound interesting. i heared a lot about xnormal, i think i should give it a try.

                            Comment


                            • #15
                              any UV seams will translate into hard edge normals.

                              wish that could change.

                              Comment

                              Working...
                              X