No announcement yet.

[Shadow Problem] BSP and Static Mesh shadows turned into pixel graphics

  • Filter
  • Time
  • Show
Clear All
new posts

    [Shadow Problem] BSP and Static Mesh shadows turned into pixel graphics


    I’ve no idea where to start with this, but I think a short introduction is needed. I’ve been working on a project with some friends for almost half a year now and recently I got the task to learn more about UDK and lighting. Being a complete beginner I did my homework, read up and got to know how it work. Now, three weeks later, I’ve stumbled upon a problem that I just can’t seem to fix.
    The lighting of our indoor environments have started to generate giant black patterns in the shadows of the level (see fig. 1). I’ve tried a variety of things; playing around with the lightmass- and post process settings, complete lightmap overhauls, changes in texture sizes (see fig. 2) and a complete reset of our lighting.

    (Figure 1, Left, standard post process settings, some screens won’t pick up the flaws. Right, scene post process mid tones cranked down to 0.2, for demonstration if the right pictures is black)

    (Figure 2, Same scene, lightmap texture resolution set to 1024)

    However, areas with more light are working just fine (see fig. 3). They might not be flawless, but they do the job. But as demonstrated above, as the light starts to bounce away from the source into corridors and unlit rooms, they start to generate these pixelated squares and squiggly lines. What confuses me the most is the fact that both static meshes and BSPs generate the same kind of patterns. So I’m not sure if this is a lightmap problem or not.

    (Figure 3, Lit room; detail light to the left, lit to the right)

    Question 1: Have you stumbled upon this problem? Where you able to solve it? If so, care to share? I would appreciate any help regarding this!

    I’ve looked over a lot of settings, to the degree where stuff isn’t making sense anymore. But I’ll try to make a short list of things I’ve done thus far.

    Lightmap Density Mode
    Current settings: Ideal Density: 0.2/Maximum Density: 1.0/Color Scale: 1

    I’ve tried to optimize the scale of our lightmaps to the best of my ability. I strive to not go above 256 (even if some larger meshes need 512, but they are rare) and I think the majority of objects in our level clocks in at 64. And yes, I try to keep the squares at roughly the same size.
    The BSP scale is currently set to 8 in most cases, but 4 could work as well.

    (Figure 4, density demonstration of a smaller room)

    (Figure 5, whole level density. White parts are not visible to the player)

    I’ve cleaned up just about everything in this level when it comes to light maps. The modular walls might have some flaws remaining, but I doubt their light maps are the main problem. We had a hard time cleaning up seems and etc. but they should be fixed now.

    Texel Density Mode
    I hardly work in this mode, but as for demonstration, it might give us a clue to what’s wrong.

    (Figure 6, functional texel density in a small, lit room)

    (Figure 7, broken texel density; different mid tones settings for demonstration)

    Similar demonstration to the first set of screenshots, but I guess it’s clearer here.

    Lit Mode
    I’m just going to dump some pictures of the map here. Some where the light works, mainly in area where it’s fully lit. Others where the light is broken, some worse than others.

    (Figure 8, machine room)

    (Figure 9, old office space)

    (Figure 10, cave)

    (Figure 11, cave, only broken part)

    (Figure 12, dark, almost unlit staircase)

    There are of course a lot more to look into than the modes, such as the post process effects and lightmass settings. I know far less about these settings, but I’ve tried to fiddle around with them. Much without any result, but I’ll give you guys the rundown of what we’ve changed in the World Info settings (within the spoiler boxes).


    * Ambient Occlusion, I’ve tried to render the scene with and without it, but without results. If requested, I'll try again.
    * We do not have a Sky Light or Dominant Point Light in this level.
    * In the cave, where almost no shadows are broken, the lights are set to 0.0 – 0.3 indirect light scale
    * In the machine room area and corridors, the lights are set to 0.1 – 0.6 indirect light scale

    Final notes
    This is where I’m stuck and I see no way out of it. I’ve also tried to fiddle with the Scene Shadows, but it basically kills off more light than I want it too. I guess I could fiddle with the Mid- and High tones as well and find a “perfect spot”, but does this actually fix the problem?
    The “Num Indirect Lighting Bounce” might solve the problem. By killing all the bounces, I could build the entire ambient light myself, but this is a highly inefficient and doesn’t actually solve the problem.
    Some of the other lightmass settings does not make any sense to me. Such as the “Static Lighting Level Scale”, Diffuse and Emissive Boost and the Visualize options. I might be missing something here that would fix this problem.

    Odd problem with shadows. If you take a look at Figure 1 you’ll notice “black patterns” in the shadows of our level. Figure 2 shows you a higher lightmap resolution, with a similar problem. This problem applies to both Static Meshes and BSPs.
    Got any ideas?

    Probably someone else can be more specific with your problem, all I have is similar experiences, and solutions and conclusions.

    With normal maps I had pixelation problems - squares on the textures but not drag marks like yours. And that was on skeletal meshes. I adjusted them best I could in the materials and it's reasonably fixed.

    Another problem I had was flashing textures on a particular static mesh - effect looked like I'd doubled surface planes (I hadn't). Eventually found it was the Dominant Directional Light and settings I'd changed. A new DDLight and everything was ok. You're not using the DDLights in your map, but changing settings from default could've messed with something.

    My suggestion is return to defaults, and then move very carefully changing from defaults. There's definitely some lighting weirdness in UDK which pops out when if you click the wrong box.


      @Snipe34, thanks for the response!

      Once I get back from the holidays, I'll revert to UDKs standard options and check if there is a difference. I'll take a look at normal maps as well, might have something to do with the "Indirect Normal Influence Boost" option and well, our normal maps in general. I doubt that's the main problem though, but it's worth to take a look at it anyway.