Announcement

Collapse
No announcement yet.

Light Map horrible shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Turns out I never fixed the issue!





    Light map density.



    I've made all my light maps with even padding, no overlapping or inverted faces. I made sure the light map density is even throughout the entire scene before exporting. These shadows were a result of having what I figured to be too low light map res. Like around 128. So I bumped everything up so the average was around 500 res. Now my pc won't render so I can't tell if this will have made a difference. I have to be doing something wrong for these shadows to be so crappy in the first place. My original issue with light maps was figuring out if a mesh's light map uvs needed to take up the entirety of the uv space or not. I found out it doesn't because it will throw off the texel density between it and surrounding meshes. Udk will just combine the uvs anyways. Where do I go from here? I turned off light map compression and turned up static lighting to 20 in the world properties. Completely befuddled.

    Leave a comment:


  • replied
    Received some help from one of my friends on this and things are looking much improved. I redid the light maps for the test tube as I completely forgot I had overlapping uvs. Woops! I also needed to fix the texel density between uv shells. It wasn't horrible, but it wasn't great either. Then I bumped up the light map res to 512 and things turned out ok, but I was still getting the ugly compression. He told me about disabling the lightmass compression setting which helps some. Also, to bump up the static lighting level from the default 1 to something higher like 20. This is the game changer from what I can tell. When you do that you allow for smaller photons to hit the surfaces. The smaller the number the larger the photon, the uglier the shadow basically. To disable the light map compression you have to go to where you saved your UDK install, UDKGame/Config/UDKLightmass.ini and Engine/Config/BaseLightmass.ini.

    Static lighting level = 1......compression


    Adjusting just the static level lighting is definitely a marked improvement.

    Static lighting level = 20......compression


    Turning off just the compression while leaving the static lighting at 1 isn't much different than having compression enabled. The shadows are less blocky and smoother though.

    Static lighting level = 1......no compression


    The real difference comes in adjusting both settings.

    Static lighting level = 20......no compression


    The higher the light map res is also makes a difference. I hope this helps someone else that runs into the same issue as I did!

    Leave a comment:


  • replied
    Thanks for the replies guys! I had a hunch it was my uvs but I wasnt sure. Is the only solution to separate the mesh into elements for a mesh that has a ton of parts like these? Cause I tried that with the platform already. I separated the whole thing into 4 chunks. Redid the uvs so they were much larger and more padded. Didnt bother with the test tube cause I still got the same bad result with the platform. The only difference being I now had to import it as 4 meshes and align them in the editor which was annoying. I can adjust the dynamic shadow radius and see if that gets me crisper shadows but im not sure why the blurriness is still happening even when I improved the uvs.

    Leave a comment:


  • replied
    your lightmap UV's are bad, too many pieces are there and on the last image the parts are too close. 512 resolution might not be too much, but the UV's are a problem.

    Leave a comment:


  • replied
    Check some of the tips ive rote here https://forums.epicgames.com/threads...3#post31901933

    Light map res of 512 is too much.In the second photo there are too many small uvs.Are they bolts or something?If so beter make them in to a normal map than actual geometry.As you see they use very litle uv space as they are too small.Thats why they dont get a nice lightmap.You coud make the smaller pieces in to a normal map and have more space for the bigger parts or separate the model in more chunks and give the small uvs more uv space that way.

    Leave a comment:


  • started a topic Light Map horrible shadows

    Light Map horrible shadows

    Well I must be doing something wrong cause my shadows look like pooo

    I only am worried about how the giant tube and and the platform/poles it's sitting on are baking





    I've baked with as high of a res as 512. Is this something in my settings? Is it my uvs? My shadows are blotchy and fugly. One mesh has packed uvs while the other has plenty of padding. Both result in bad shadows. HELP!
Working...
X