Announcement

Collapse
No announcement yet.

Level Streaming Crash.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I have random crashes when loading a level, but only in the 32 bits executable. The logs dont show anything. And as I said, its random.

    Works perfect on 64 bits. I think its a problem with the landscape.

    Leave a comment:


  • replied
    Any problem I've had where this has appeared (copy/posted from your error log above): Address = 0xfda1940d (filename not found) [in C:\Windows\system32\KERNELBASE.dll] has been to do with faulty static meshes. From a 'faulty' mesh that imports to UDK fine and everything seems to work but obviously doesn't.

    But could be something to do with Landscape, I dunno... that's another potential nightmare.

    I rebuild regularly, particularly after new imports, and both times I had problems I traced to recently imported meshes which I fiddled around with, rechecking, fixed, reimported.

    Leave a comment:


  • replied
    Sorry,cant help eighter.I suggest you put this in the programing part of the forum and make a thread at game artisians and polycount(since sadly most of the pros are not here anymore)You have better chances finding more help there.
    And if you find the solution please post so that others woud know.

    Leave a comment:


  • replied
    Can't help with this but its better if you break up that scary block of text as it'll probably lead to more replies... You can put the logs into a text box too and it'll look better. Try 'Go Advanced' when posting...

    Leave a comment:


  • started a topic Level Streaming Crash.

    Level Streaming Crash.

    Hello Everyone,
    We are using the latest version of UDK 3 and currently in the Alpha stage of development. Recently, while integrating our levels and streams, we are experiencing a crash that occurs while playing our game (See the end of the post for the log). The exact error message is as follows:

    Illegal call to StaticFindObject() while serializing object data or garbage collecting!

    Some details about our game: Our game extends from the basic GameInfo class and utilizes very few UDK/UT existing Unrealscript classes. Almost all of our Unrealscript classes are extending from base classes such as Actor and Pawn. We do not extend from the base class Object anywhere in our code and do not have Actors which store references to Objects ( and vice versa ) other than existing UDK base classes which extend from object, such as StaticMeshComponents, SkeletalMeshComponents, and similiar classes.

    Our level streaming setup consists of one overall persistent layer and several "base" levels within persistent. When the game first loads, the persistent streams in the first "base" level, then the kismet within that "base" streams in the other sub-levels (basically layers). When the player reaches the end of the first "base" level, the camera fades, the next "base" level streams in (which then streams in it's sub-layers), we teleport the player to the new level, unload all of the previously streamed levels, then fade the camera in so the player can continue.

    The error most often triggers a short duration after we have unloaded a previous level and streamed in a new level. Most often, the error is unpredictable and seemingly hard to reproduce at times.

    We did some digging through the forums and noticed there were others who experience a similiar crash. The issue seemed to crop up for people using Landscapes. We do use a landscape in our game but I do not believe this is the issue. However, we are not ruling it out. The Landscape we are using is very basic. It is in the first "base" level rather than the persistent, so we unload the landscape after the player moves to the second "base" level. It is not very big, has a simple heightmap, and still uses the dev texture for now.

    See this post: https://forums.epicgames.com/archive.../t-917067.html

    It would be very helpful if someone could shed some light on what this error entails. We have been trying to debug it but are unable to narrow down what is causing the issue.

    Here is a snippet of the log with the crash details:

    Code:
    [0834.39] Pawn: PG_Helmet.OnHelmetEquip: OnHelmetEquip being called! 
    [0834.39] Pawn: PG_Helmet.OnHelmetEquip: PG_AIActor_64 
    [0857.49] Pawn: PG_WaveGroup.(Active).CheckProgressOfWaveGroup: PG_WaveGroup_77 
    [0857.49] Pawn: PG_WaveGroup.(Active).CheckProgressOfWaveGroup: WaveGroup Has finished and all enemies are dead. Going to state FinishedSpawning 
    [0857.50] Pawn: PG_CombatWave.(Active).CheckProgressOfWaveGroups: PG_CombatWave_35 
    [0857.50] Pawn: PG_CombatWave.(Active).CheckProgressOfWaveGroups: CombatWave has finished with all WaveGroups complete! 
    [0857.50] Pawn: PG_CombatWave.(WaveFinished).OnWaveEnd: OnWaveEnd 
    [0857.50] Pawn: PG_CombatEncounter.(EncounterFinished).BeginState: PG_CombatEncounter_11 
    [0857.50] Pawn: PG_CombatEncounter.(EncounterFinished).BeginState: Combat Encounter has finished! All waves are complete 
    
    [0858.88] Critical: appError called: Illegal call to StaticFindObject() while serializing object data or garbage collecting! 
    [0858.88] Critical: Windows GetLastError: The operation completed successfully. (0)
    [0871.55] Log: === Critical error: ===
    Illegal call to StaticFindObject() while serializing object data or garbage collecting! 
    
    Address = 0xfda1940d (filename not found) [in C:\Windows\system32\KERNELBASE.dll] 
    Address = 0x3fe18ef5 (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe] 
    Address = 0x3fdd672b (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe] 
    Address = 0x3fe001f6 (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe] 
    Address = 0x3fe09806 (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe] 
    Address = 0x3fe0a292 (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe] 
    Address = 0x3fe13e75 (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe] 
    Address = 0x409ac51f (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe] 
    Address = 0x409ad1fb (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe] 
    Address = 0x41a2d1ea (filename not found) [in D:\Perforce\FowlPlayGames\UDK\Binaries\Win64\UDK.exe]
Working...
X