Announcement

Collapse
No announcement yet.

Combined meshes and lightmass problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Combined meshes and lightmass problem

    Hey guys,

    I've been having some trouble with lightmass and complex meshes when combined.

    I've tried to import all the building as a fbx and combining the mesh. It's a huge and complex building with lots of little pieces and pillars so it's easier that way. The problem is that when I'm doing lightmaps, not only it doesn't let me create a new UV channel in the Static Mesh editor (been having to do it in max) but it reads the various meshes' UVs as overlapping. The results are consistent with the overlapping.

    It's driving me crazy! I've been having to split the meshes into huge chunks and making a simple UV space for all of it. So I need a huge lightmap resolution and still looks bad: Jagged shadow edges, etc.

    Any advice or method to tackle this? I can't believe there isn't a simpler way to import complex buildings into UDK and light them.

    Cheers!

    #2
    It doesn't really make sense to have the meshes combined, why are you doing it that way? You should be using smaller meshes and building more modularly, look at the levels Epic made for example in UDK. Every mesh is separate.

    Comment


      #3
      I know, but in this project (Archviz) the building isn't really modular. Old renaissance palace. Somethings I can repeat but the main building is very diverse.

      Comment


        #4
        Can you post an image of one of the combined meshes? I still think it would be better to split it, how are you even texturing it, multiple uv channels?

        Comment


          #5


          Here's an example. The exterior mesh. I'm using only a UV channel for diffuse.

          Comment


            #6
            You're way better off breaking the building up into separate, smaller chunks with their own unique lightmap UVs with no over lapping. The larger and more complex a combined mesh is, the less space you have for lightmap UVs which means EXTREMELY large lightmap sizes to get a decent result (less jaggy shadows, more detail etc.) since there wont be as much pixel space for the surface.

            It's best to understand the limitations of the engine before tackling such a large project. UDK works best with multiple pieces rather than one large mesh. Your best option would be to separate the unique portions into a bunch of smaller, separate meshes with unique lightmap UVs. And to make things easier for placing them in the level, set all the pieces to have their pivot point in the same place (0,0,0 would be a good default position.) that way you can just drag all the pieces into the level and set their location to 0,0,0 and be done with them. this'll probably take some time, but there's no fast, easy fix for this sort of thing with where you're at.

            Comment


              #7
              That's pretty much what I'm doing right now. Still deciding how to organize the pieces and UV islands. I would love it if the meshes could just pop at 0,0,0 when placed. Any idea how to do that?

              Comment


                #8
                Originally posted by Waracle View Post
                That's pretty much what I'm doing right now. Still deciding how to organize the pieces and UV islands. I would love it if the meshes could just pop at 0,0,0 when placed. Any idea how to do that?
                I don't know of a way to automatically put meshes at 0,0,0 when added, but the easiest method would be to just add all the pieces into the level in any location, select all of them, then right click on the translation mode button (the cross made of four arrows in the top tool bar) and enter in 0,0,0 in the box that comes up. All the selected pieces should then snap to the 0,0,0 position in the level. It's not automatic but it's dead simple to do.

                Comment

                Working...
                X