Announcement

Collapse
No announcement yet.

Optimising My First Environment

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by darthviper107 View Post
    But since your entire scene is using dynamic shadows it's slowing down.
    Wait, why is my entire scene using dynamic lighting? I thought only the InterpActors and SpeedTrees would use the dynamic lighting and the other static meshes would use the static lighting; which should be baked.

    Comment


      #17
      I don't know, from the screenshot you can see the shadows how jagged the edges are and how there's a shadow artifact on the sides of buildings, that's all signs of dynamic shadows

      Comment


        #18
        Originally posted by darthviper107 View Post
        I don't know, from the screenshot you can see the shadows how jagged the edges are and how there's a shadow artifact on the sides of buildings, that's all signs of dynamic shadows
        Okay, I'm gonna go through my scene and just try optimise it based on the advice - I've been a bit clumsy with the rocks so I'll start by trying to remove some of them and improve the framerate.

        PreComputed shadows is active on all of the buildings; they're all also using their defaults so I'll go through them and turn off "Accept Dynamic Lights" as well as "Accept Dynamic Dominant Light Shadows" as the objects are static and my DominantDirectional light is giving off a static light therefore these buildings shouldn't require Dynamic lighting on them(?)

        Thanks for being patient with me. I'll keep tampering and seeing if I can get this to work efficiently.

        Comment


          #19
          You should also make LOD's for all of the objects in the scene. It won't make a huge difference, but it will definitely help.


          Sent from my iPhone using Tapatalk.

          Comment


            #20
            Originally posted by DinoSrdoc View Post
            You should also make LOD's for all of the objects in the scene. It won't make a huge difference, but it will definitely help.


            Excuse my ignorance, but I'm not 100% sure how LODs work (I know they mean Level of Detail). I've got Generate Building LODs checked when I build lighting though.

            Comment


              #21
              Don't worry, it really isn't all that complicated. Here's the link to the official docs, http://udn.epicgames.com/Three/MeshS...ationTool.html. To sum up that doc, you just select your mesh, go to the mesh editor, choose mesh simplification tool and fiddle with the settings until you're happy with them.

              Comment


                #22
                Ok cheers.

                Comment


                  #23
                  Having to come back to this thread because the issues persist.

                  For a short period of time (after following all advice on this thread) my framerate was acceptable, at around 40 frames. I emphasize on acceptable because my machine should be able to achieve a flawless 60, and does so on the example maps.

                  I've done the following:
                  - Reset all static meshes to their default settings
                  - Deleted all lights and added them again. Only basic settings (brightness, colour, etc.) have been changed on any lights
                  - Baked static lighting (build lighting) to preview quality
                  - Ensured that no meshes have an unreasonably high polygon count

                  I have a deadline in < 48 hours and I need to record the final project video, but I can't if the framerate is this poor.

                  Below are screenshots of stats that I was told to use but I don't really understand what I'm looking for. D;

                  http://puu.sh/5Qg2u/c96547d89f.png
                  http://puu.sh/5Qg1L/de7faf6eac.png
                  http://puu.sh/5QfWd/b4531f1878.png

                  One of the environment: http://puu.sh/5QfUc/b0083aba52.png

                  Any help highly appreciated in this time of desperation!

                  Comment


                    #24
                    You've got way too many draw calls, given the fact it's a rather simple scene with a reasonable amount of individual meshes.
                    I'd guess there is still some dynamic lights in the level which are affecting multiple meshes objects and therefore boosting up the draw calls.

                    Comment


                      #25
                      I thought there was something wrong there, mAlaAv!An! It's also reading as 24 lights when I only have 5 in my scene.

                      There is a Skylight, a Dominant Directional Light and three Pointlights. They are all using their default properties.

                      There's a few small InterpActors in the environment which of course would use the Dynamic channel from the Dominant Directional Light and everything else is a Static Mesh so I'm not sure why the Dynamic lighting would be getting used on those Static meshes? I've built my lighting so this should have baked static onto them?

                      Thanks for the reply

                      Comment


                        #26
                        Update:

                        Deleted all lighting. Built lighting and played in UDKGame. Framerate 58.

                        Screenshot: http://puu.sh/5RfQi/2cbb2b0dac.png

                        Comment

                        Working...
                        X