Announcement

Collapse
No announcement yet.

Map crashes when loading in editor after adding light function material to light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Map crashes when loading in editor after adding light function material to light

    So... last night I saved my map after adding a cloud material that I created as a light function material into the light function slot of a dominant directional light(this was to simulate the cloud shadows on my landscape terrain). Tried to load the map this morning, and it crashes the editor while loading.

    Tried to open my autosave backup file, but for whatever reason it was a backup of my map that was saved at the exact time that I had saved my original map file, so the autosave contains the same changes as the current map and crashes in the exact same way (which IMO is not a smart method for autosaving, guess I'll have to change that next time around).

    Is there any possible way to fix this issue in my map so that it loads? Or am I looking at a total loss of the map and I need to redo everything I have done in it(which will take me several days just to get back to where I was with it).

    I'm hoping there is some method of manually going into the code for the map file and deleting the light function properties from it, but I haven't tried anything like that in the past...

    Any ideas?! Please tell me someone knows a way around this, you will be saving me from a lot of work and major headaches!

    #2
    Did you save the material in the same package as the map file? (Meaning, the package that you put the material in is named the same as your .UDK map file).

    If so, that usually breaks stuff.

    Comment


      #3
      Nope, it's all in a separate package. Unfortunately the issue is not related to the light function, I have now narrowed things down to two different textures within one of my packages that contains most of my work. For what ever reason, trying to fully load that package, or just load either of those two textures, results in a crash. So the package that contains all of my stuff is now simply useless. I can't use anything from that package, as trying to move them/save them/copy them in any way results in a crash because any of those actions requires the package to be fully loaded, which crashes because of those two single texture files..................

      I made a new thread about it because the issue is content related and not level design related, and included the crash log, found here: http://forums.epicgames.com/threads/...8#post31528328

      Comment


        #4
        Backups backups backups.
        Always make multiple history backups of your work at minimum once each day, preferably twice.
        That way you won't lose more than one day's work.
        Never rely on autosaves, and never assume that something in UDK or your computer won't corrupt the current set of packages and files.

        Comment

        Working...
        X