Announcement

Collapse
No announcement yet.

Transparent material seams, seeking advice

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Transparent material seams, seeking advice

    Hello, I'm new to UDK and these forums. Please let me know if there's anything I can do to clarify my question

    I've created a 60% alpha, black material for use on a race track. Think Rainbow Road meets Tron.


    It looks great from a distance, but up close, there are seams. The seams do not appear at the edge of the road's individual polygons/surfaces - they appear more frequently. View full size to see what I mean:




    Here is a screenshot of the material graph. The texture is the default "Black" used by UT - a 32x32 black image. Note that "Mip Gen Settings" on this texture is set to Sharpen5. Changing this property did not seem to have an effect.



    I have played with **** near every option on the material. This one seemed promising:
    "Translucency Inherit Dominant Shadows From Opaque"
    Whether this material should inherit the dynamic shadows that dominant lights are casting on opaque and masked materials behind this material. This is useful for ground meshes using a translucent blend mode and depth biased alpha to hide seams
    But checking that option had no effect.

    If you have any thoughts, or think that more screenshots would help, please let me know. Thanks

    #2
    Just scale up the material and then see what happens -> then the seams should disappear

    Comment


      #3
      Try using a constant instead of a texture sample for your diffuse.

      Comment


        #4
        Originally posted by fighter5347 View Post
        Just scale up the material and then see what happens -> then the seams should disappear
        I'm totally new to UDK. Is this the type of scaling you're referring to:

        I'll give it a try when I get home

        Comment


          #5
          Originally posted by James Ordner View Post
          Try using a constant instead of a texture sample for your diffuse.
          Hey James, what type of constant can plug into the diffuse slot? Vector 3?

          Comment


            #6
            Originally posted by j1mmie View Post
            Hey James, what type of constant can plug into the diffuse slot? Vector 3?
            Nevermind - found the answer. Constant3Vector. Thanks, will try this soon.

            Comment


              #7
              Constant 1 will work in this case too. Constant 1 is for single values (color-wise: grayscale), and constant 3 is a vector with 3 values, which can be interpreted as RGB color.

              Comment


                #8
                It turns out neither solution worked. Changing the texture to a constant, or adjusting the scaling on the surfaces. Both still have the seams, and they don't appear to look any different than before.

                I wanted to point out that this bug does not appear in the viewport while editing. It only appears when playing, either in viewport, or as an external window. Not sure if that provides any more clues.

                Any more suggestions would be greatly appreciated. Thank you

                Comment


                  #9
                  Does it show up in the editor when you're in Game View (the G key, or the G button on the toolbar)?

                  Comment


                    #10
                    Have you already rebuild the lighting and the geometry? Have you made the mesh with bsp?

                    Comment


                      #11
                      fighter5347: I've rebuilt lighting. Not sure how to rebuild geometry, I'll try to find out later. This map was actually created using one large, cylindrical brush. Maybe I should try making static meshes instead?

                      Comment


                        #12
                        Are the material 'Usage' settings set correctly?

                        Also, big plus for the meshes! BSP brushes can often generate small rendering errors like these.

                        Comment


                          #13
                          Apply the material to another mesh / piece of BSP, if you haven't already, just to ensure it's a material problem and not a geometry problem

                          Comment


                            #14
                            Originally posted by James Ordner View Post
                            Does it show up in the editor when you're in Game View (the G key, or the G button on the toolbar)?
                            Just tested - the seams do NOT exist in Game View.

                            Comment


                              #15
                              Originally posted by TheJamsh View Post
                              Are the material 'Usage' settings set correctly?
                              I enabled every usage option - they had no effect on the seams. I'm going to try with a static mesh now and see what happens.

                              Comment

                              Working...
                              X