Announcement

Collapse
No announcement yet.

UDK Mesh Paint issue - can't paint!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK Mesh Paint issue - can't paint!

    Solved! In case anyone else is wondering - it turns out I hadn't enabled 'Per Poly collision' in the Static Mesh Editor Properties for the cobblestone material.

    ---

    Hiya folks!

    I come to you today with an odd problem that's been plaguing me on and off for a while, but now has come to a point where it's really causing trouble for me.

    On a number of my imported meshes, various groups of vertices (seemingly separated by Element, from what I can tell in Max) do not allow me to paint on them with Mesh Paint

    Normally when you hover the Mesh Paint brush over a mesh, you can see its vertices, however these areas do not show the vertices. I've tried Googling this many times and simply can't find any solution, though I'm sure it doesn't help that I don't exactly know what to search for!

    I've tried messing around with the various settings but nothing seems to change anything - occasionally, it 'decides' to work again for a little while, and then steps working. I don't know if it's some hotkey I keep pressing, but I can't figure it out.

    Here's a screenshot of the issue. As you can see, painting on surrounding vertices (sidewalk) will in fact effect the 'unpaintable' vertices (the cobblestones). But I cannot paint directly onto the cobblestones.




    Any ideas what's happening here?

    Thanks!

    EDIT:

    Oh, I'm using FBX format, and here's a screenshot of my import settings:

Working...
X