Announcement

Collapse
No announcement yet.

Dominant light bleeding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dominant light bleeding

    Hey folks!

    I have a little light bleed problem with my first wall and floor planes i made. I want to make modular stuff i can work with, but there is some strange light bleeding under these walls. Any idea what can cause that?

    The model is a plane with 2sided texture, i've used wall pieces last time, but it take too much lightmap and i saw bleedings on the edges.



    Thanks for the help.

    #2
    If your vertices go beyond the edges of the other walls then the light from the outside can bleed over onto the interior, increasing the lightmap resolution can help but you'd want to make sure that the wall corners don't go beyond each other.

    However, for something like that, you're not benefiting from using a modular setup, since those walls are so simple that having them all as a single mesh would not slow it down at all. The number of objects though can actually slow down performance which would be a waste considering how simple those objects are.

    Comment


      #3
      Had to recompile it.
      FAIL
      Last time it didnt worked though, maybe it was on preview quality.

      EDIT: Well, is there a way to make a lightmapped dominant light and a dynamic too? Or i have to choose?

      Comment


        #4
        Well, the walls and floors' edges is on the same grid so can't be a hole between them, even if i move thru the 2 object each other i see the light bleeding thru the model.
        Maybe because its a 2 sided plane? I guess everyone is using these for indoors and such, a real wall will take too much lightmap.

        Other modular sets have this problem too? I guess they mostly working only with lightmaps though.

        Comment


          #5
          The reason for the bleed is simply because the map is not high res enough to put a shadow where it needs to be. You need extremely high res light maps to avoid that completely and basically it's not really an option.

          Normally you would not build everything out of single planes. You would have some amount of thickness to your walls and with having that will mostly avoid this sort of problem. The thickness allows a shadow to cast underneath the wall and therefor a much lower res map is possible. since a shadow bleeding into a shadow is not noticeable.

          It could be possible for you to only use planes but then I think you might have to build everything very exact so there are no overlap.. anywhere, of any meshes. So you'd always have vertex alignment on everything. This way there are no places for light to cast behind something, causing the light map to have light in it that is never seen but will bleed underneath your wall.

          Comment


            #6
            It could be the mipmaps, by default as you move further away from an object it will lower the resolution of the lightmap
            A lot of times modular stuff in games are more detailed and have details that show more separation. And if it's a big game then they might not have the space to keep complete environment assets even if they are simple.

            Comment

            Working...
            X