Announcement

Collapse
No announcement yet.

lighting changes while editing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    lighting changes while editing

    So, right now, when I move an object while I'm editing my scene, it throws off all the lighting until I rebuild again. Is there a way to turn that off? I'm okay with it not updating the lighting until I rebuild. What drives me crazy is when my entire scene turns bright whitish, so much so that I can barely see to keep moving my objects around.

    Also, if anyone knows, what is a typical amount of time for it to take to build the lighting? Obviously preview vs production quality will be different, but it just seems like it's taking me way too much time. I can't imagine if I had a more complicated level and were trying to do this. Would I have to let it run over night?

    Thanks!

    #2
    There's no way to disable that. Whenever you move something all the lightmaps are removed since they won't match up if something is moved. Your best bet is to work in unlit mode for a while and build lighting less often (ie, if you build them once and get good results, there's no reason to keep rebuilding until you make adjustments to the lights or add new lights)

    As for how long it takes to build lighting, that depends on the size of the map, the lightmap sizes, the lightmass settings, and what type of computer you have so it varies. A typical fully decked out map could take hours and hours to build. It's best to use preview lighting for a while then bump it up to production when you feel confident those settings are good. I tend to do light baking overnight on large scenes after I've finished working for the day.

    Comment


      #3
      Okay, thanks.

      Comment

      Working...
      X