Announcement

Collapse
No announcement yet.

Transparent Foliage become blurry in DoF volume [video posted]]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Transparent Foliage become blurry in DoF volume [video posted]]

    I never was a big fan of Speedtree, but figured I would try it out to see what it was like and it wasn't too bad. However when I created the material for the fronds of a palm tree, in DoF I quickly noticed a major issue I could not fix.

    The soft masked transparency was being affected regardless of the range of the DoF.

    In other words, the leaves get really blurry as long as they are viewed with the sky in the back ground, if i "Fly up" and look down, with the terrain as a background, there's no issue.That's my problem.



    In my material settings, I have:
    MATERIAL
    Opacity MaskClipValue : 0.8
    Blend Mode: Blend_SoftMasked
    Lighting Model: MLM_Phong
    Two Sided : True
    TRANSLUCENCY
    Allow Fog: True
    Allow Translucency DoF: True
    USAGE
    Used with Speed Tree: True

    I have tried quite a few other settings, but this is what I currently have.
    I intend on having a PostProcess volume outside in this map.

    Those Volume settings are:

    EnableBloom True
    Enable MotionBlur True
    Enable Scene Effect True
    Allow abient Occlusion True
    BloomScale 1.0
    Bloom Threshold 1.0
    Bloom Screen Threshold 10.0
    DoF Focus Distance 0.0
    DoF Focus Position 0.0 0.0 0.0
    DoF Interp Duration 1.0

    I have no idea if this is any help to see these settings but they are here. And any help is greatly appreciated.

    #2
    This is a limitation of the Soft Masked blend mode and not related to Speedtree.
    UDN page: "SoftMasked only affects the depth buffer only in areas of maximum opacity. As the fog rendering is based on the depth buffer [as well as DoF] some pixels become fogged too much. Tweaking the Opacity Mask Clip value to be smaller helps but then the result appears to be less soft"

    Comment


      #3
      I also had this trouble with a transparent material setting before i made it Softmasked.

      Its something to do with the material being transparent and being inside of a DoF volume.

      Comment


        #4
        i can post a video if you like. Hopefully a visual representation will help you to understand more of what is going on.

        Comment


          #5
          http://www.youtube.com/watch?v=GdfNB3Alycc

          Comment


            #6
            Translucent is even worse, usually you should use Blend_Masked.
            Is there a specific reason why you are going with a PP Volume instead of adding DoF via the world PP settings or a custom PP Chain?

            Comment


              #7
              well that was exactly what i did but i thought that the volume had to be added to make it effective? so youre saying that the volume is not needed if the settings in DoF in the world properties have been set?

              Comment


                #8
                i will attempt removing the volume and post my results in just a moment

                Comment


                  #9
                  This had no effect on the result of the blur, it still occurred
                  (as the volume was not set to override the world properties)

                  Comment

                  Working...
                  X