Announcement

Collapse
No announcement yet.

UDK - strange spots problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK - strange spots problem

    Hi,

    At the beggining - sorry for my english; if something will not be understandable, please ask.
    I'm making my bachelor diploma using UDK and 3ds max 2012 - I have to model my department's building.
    I've read so much about modular modeling and have been to so many places like polycount and epic games forums threads, not mentioning solid
    research in 3ds max and even Maya for better lightmap UV snapping.

    So, my problem are those strange spots (not seams, I already know how to handle them):
    http://imageshack.us/a/img515/474/screenplamy3.png
    http://imageshack.us/a/img571/152/screenplamy2.png
    http://imageshack.us/a/img6/3513/screenplamy.png

    The scene is setted up with some bricks from my package and default point lights.
    I know that previously there were people asking about the same; I've read replies to their topics but nothing helped.
    That's absolutely sure - the spot generator is Ligthmass. Turning it off would solve the problem in a simple way. But then,
    I would have no lightmass, and therefore - no coolness in my work.

    Here's the list of things what I've been trying to do:

    UDK
    - Turning GI / AO in scenes
    - Playing with shadows exponent
    - Inserting other types of lights
    - Rebuilding scene in new blank maps
    - Keeping high lightmap resolution (512)

    3dsmax:
    - Taking care of good mesh
    - Setting smoothing groups like 0,1 or 0,0 + auto Smooth
    - Setting GFX mode from Nitrous to DirectX with Qualified normals ON
    - Checking normals with 'edit normals' modifier
    - Using FBX pipeline with smooth groups, tangents and binormals etc. and
    making sure to check "explicit normals" in UDK importer

    I've spent a lot of time trying to resolve this and now all I have is just the feeling of resignation and sadness.
    Is there any solution for spots problem?

    #2
    I would say that looks like a lightmap issue, like not high enough resolution, but you said you are using 512 so it should be OK. make sure to check that your lightmap UV's are good.

    Besides that, I know that emissive lighting (using an emissive texture to create light) can cause bad graphical problems like that, but you said you are using point lights so that probably isn't it.

    Also try setting in your material, under the properties, the Misc category, turn off the box for Allow Lightmass Specular, sometimes that can help.

    Comment


      #3
      Thanks. I have checked for emissive ligthing, but it wasn't it. Almost the same for Allow Ligtmass Specular- old spots have gone but new one appeared.
      What do you mean by checking if my lightmap UV's are good? More accurate grid snapping?

      Comment


        #4
        There are posts in the architectural forum on how to get lightmaps cleaner if you're set on using very pale materials. Normally such blemishes are expected to not be noticeable by the time most textures go on.

        Comment


          #5
          Thank you, I haven't noticed architecture subforum.
          I found kind of solution to lightmass spots - Indirect Normal Influence Boost in World Properties should be set to 0.
          Spots are gone I'll read some more.

          Comment

          Working...
          X