Announcement

Collapse
No announcement yet.

UDK Dominant Directional light not bouncing.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK Dominant Directional light not bouncing.

    Hey all,

    Title pretty much says it all, the dominant directional light in my scene isn't bouncing in the slightest, I'm just getting pure black shadows.

    Here is a screenie with my world properties -> lightmass settings, and the Dom Directional properties.



    Think it may have something to do with the LightShadow_Normal instead of LightShadow_Modulate setting, but everytime I try to change it to modulate, it immediately reverts to normal, as if the option is not available. I though modulate was default in UDK?

    Thanks for any help!

    #2
    Have you tried adjusting the environment color and the shadow color in the default post processing settings?

    Comment


      #3
      I suggested the same thing on this thread, but he wants to know how to achieve actual bounce lighting, not just have more realistically colored lighting.

      Comment


        #4
        Increase the amount of light bounces then? I feel like simulating exactly how light bounces will be rather difficult in UDK, hence all the other things like environment lighting to alleviate that.

        If increasing the amount of bounces in the world properties doesn't help, the only other option besides adjusting the environment lighting would probably be to fake it with well placed point lights that don't cast shadows.

        Comment


          #5
          Are you sure you did not mess with any Lightmass settings on your materials, models or the light?. In the material make sure Diffuse Boost is 1.0 and the same for the models and on the light make sure Indirect Lighting Scale is on 1.0.

          With any one of those or any combination of those set to 0.0, you will not get any bounce. With the model and material settings, it would have to be on all the models or all the materials otherwise you might see some bounce here and there.

          By default, if everything has default settings, you should get a fair amount of bounce.

          Comment


            #6
            Detective Ordner in the room! :P Thank you for explaining my situation.

            Jessie G: The reason I am puzzled is because I was under the impression that with default setting there should be plenty of bounce. The idea of global illumination is that it should attempt to achieve realistic bounce simulation. But I shall almost certainly be using Environment colour now I know the use of the tool. I would just like to sort this problem too!

            obhib: The light is brand new, I deleted the old one and created a new one to get it working, so it shouldn't be there. For the models, I have simply pumped up the lightmap resolution on a few of them. As for materials, we are using a master material, but not on every single material, the one on the exterior floor you see there is simply a diffuse, spec and normal material setup in UDK with no changes. I will however go in and double check this now.

            I personally believe it is something to do with the world properties, or is that really unlikely?

            Would copying all the BSP + Static meshes and pasting into a fresh level help sort if that is the cause of the problem.

            Comment


              #7
              Tried editing the environment colour (even up to pure white) with absolutely no difference to the scene whatsoever!

              Comment


                #8
                What I can suggest as a simple light baking test is to use the default map that opens up. The one with the floor, box and sky dome. When that opens, just click to build lighting, don't do anything else. See if you get the full GI build as it is by default. If you're having problems there, then your problem may be related to config file changes somewhere. Or in a worse case, some installation error or something that involves re-installing the UDK.

                If you don't have problems there, then it has to be from your scene. Whether it's a setting or purely a bug or something. All I can suggest then is to start 100% from a clean map, drop new models in, drop a new light in and build lighting and see the results.

                All I can really say for sure is that, by default, you should get a decent bounced light result without having to really do anything.

                Comment


                  #9
                  Thanks obihb, I'll give this a go, I have a feeling you are right...

                  Have been working on the lighting in my scene regardless, and now I'm a bit more puzzled. My static meshes aren't casting shadows, and the ambient occlusion doesn't seem to be very prevalent, if you look at where the counter or barrels meet the floor

                  Comment


                    #10
                    Everything looks like it is lighting properly with AO and shadows, except for the floor. Check to make sure your lightmap resolution is turned up high enough for the floor, and make sure that you aren't using per-vertex lighting.

                    Comment


                      #11
                      its got 1024x1024 lightmap resolution. It's just a tesselated flat plane static mesh that I vpaint on, it's not got per-vertex lighting on. Confuzzled!

                      Comment


                        #12
                        Whenever I have this problem it's always with floors. And it's always because I didn't do lightmap UVs... I always forget lightmap uvs on the simple stuff.

                        Comment

                        Working...
                        X