Announcement

Collapse
No announcement yet.

Build lighting + change light = lag

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Build lighting + change light = lag

    I've been working on a level for a while without building lighting. Just now I finally built lighting and it was looking good (no lag). Then I changed a light source and now the editor is lagging constantly, it's almost impossible to do anything in Lit mode. This disappears if I rebuild lighting again.

    Why does this happen? is there a way to revert it back to how it was before? I don't need the lighting to be completely representable with the final lighting.

    #2
    Before lighting is built it is using dynamic shadows which don't run as well as baked lighting, whenever you change something with a light then it invalidates the baked lighting so it has to be rebuilt, there's no way to avoid that.

    Though it should only be trying to count the shadows for one light at a time so it shouldn't be absolutely terrible that way.

    Comment


      #3
      can i delete the baked lighting? and work with the dynamic lighting instead. how am I supposed to work on this level if it's lagging crazy every time I change a light source?

      Comment


        #4
        Perhaps your computer can't handle the work

        Comment


          #5
          I know this may not be the most practical answer, but i guess any help may be useful to you.

          If your map is filled with only static meshes do you have the same problem? I notice that i get a similar problem, although quite minor when the map is made mostly out of BSP's. Just discovered this as converting ut2004 maps. Old maps use BSP's a lot, newer not so much.

          Also, you may want to use unlit mode when working on stuff, then just flicking to lit mode to get an idea, or use unlit mode when moving.

          Hope this helps

          Comment

          Working...
          X