Announcement

Collapse
No announcement yet.

Particle System Collision Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Particle System Collision Problem

    Hi everyone!

    I have a strange collision problem with particle systems. It should work ok, because I can see it working properly on cascade and when I check the "Real Time" property in the editor but in game the particles do not collide properly with the floor. Do you know any way to solve this? Another point is that I have tried those PSs on the "Empty" levels default in UDK (Afternoon Light etc) and they work properly but only sometimes! It is very strange.

    Thanks in advance

    #2
    I think this has to do with particles being scaled back on processing. You'll notice the lower your frame rate the less particle collision will work. I could be wrong but I've noticed this happen when I do like, a fraps recording at 30fps and 60 fps, on 30, particles will stop colliding but at 60, they will collide. So, that's my theory of what's going on.

    Comment


      #3
      The PhysX particles don't collide in the editor but they do ingame. Are you using them?

      Comment


        #4
        Originally posted by Santewi View Post
        The PhysX particles don't collide in the editor but they do ingame. Are you using them?
        It is just the opposite. They collide in the editor but not ingame

        Comment


          #5
          Originally posted by reixons View Post
          It is just the opposite. They collide in the editor but not ingame
          So you are using PhysX particles?

          Can you post the PhysX particle system properties?

          Comment

          Working...
          X