Announcement

Collapse
No announcement yet.

collision isn't working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Thank you all so much for your help

    Leave a comment:


  • replied
    http://forums.epicgames.com/threads/...-Builder-Brush

    Leave a comment:


  • replied
    You can either import a static mesh without collision and double click it in the content browser and click "Collision" in the top menu of the statics mesh editor to add collision or put the builder brush around the mesh when it's in the scene and from the list of volumes choose "blocking volume".

    Leave a comment:


  • replied
    I can create collision straight from within udk? How do I put collision hulls to use?

    Leave a comment:


  • replied
    If you don't mind doing it all from within udk I would just do it tht way instead of beating your head against the desk. You can do a collision hull or blocking volume.

    Leave a comment:


  • replied
    My collision box is slightly larger than the mesh itself but that's what I did for some of my other meshes and they turned out just fine, so what am I missing?

    Leave a comment:


  • replied
    [QUOTE=JessieG;30722179]You use duplicates of the object? That's probably not a good idea because then you have way more polys than needed to create collision. You might as well save a step if that's how you do it and turn on per poly collision.

    Thanks for the heads up will keep it in mind. Our enviroment artist does collision so when I say I do this it is a temporary thing just to test play meshes. Since I'm not a modeler I instance the object in max and name one as collision. A example use to this is a floor of a building I want to Import to run around the map just to get a feel for the scale and flow. I don't want to spend a lot of time setting things up since it will not be final or even saved this way when I exit udk. I want to check this increase in polys you talk about because I don't think I have ever noticed.

    Leave a comment:


  • replied
    Originally posted by stephan360 View Post
    You say it completely covers the mesh? What do you mean I'm not that experienced in collision but when I create it in max I simply clone the object and the name the clone with ucx. Meaning when you look at my object you only see one mesh In max because they fit together Exact same size of geometry I am not sure if this helps or if any issues come up if your collision box is larger then the mesh?
    You use duplicates of the object? That's probably not a good idea because then you have way more polys than needed to create collision. You might as well save a step if that's how you do it and turn on per poly collision for your meshes.

    Leave a comment:


  • replied
    You say it completely covers the mesh? What do you mean I'm not that experienced in collision but when I create it in max I simply clone the object and the name the clone with ucx. Meaning when you look at my object you only see one mesh In max because they fit together Exact same size of geometry I am not sure if this helps or if any issues come up if your collision box is larger then the mesh?

    Leave a comment:


  • replied
    look where? In the static mesh editor? Because, in there, the mesh is completely covered in boxes. Granted, the boxes are multicolored, and I have no idea what that means, but the mesh is still covered. I can't think of what I missed. In 3ds max, I created a UCX_Box_002 that completely covers the mesh.

    Leave a comment:


  • replied
    maby it's a bug in the collision mesh. go back and look for someting that you may have missed.

    Leave a comment:


  • replied
    The gunfire is passing straight through the geometry and the collision of the object and flies away into the horizon.

    Leave a comment:


  • replied
    If I remember correctly, gunfire on a mesh is per poly so it doesn't take the collisions into account (this helps prevent bullet holes and other decals from floating in the air instead of appearing on the object itself.

    Are the bullets passing through the collision but still contacting the geometry? If that's the case and you don't want that to happen, a blocking volume set to block gunfire might help. If it passes through the actual geometry of the model, I'm not sure what could be causing that.

    Leave a comment:


  • replied
    It still doesn't happen. Weapon fire still goes through it. I don't know why though, since I did the exact same collision procedure for my other models and they block everything fine, but for some reason this particular model doesn't block everything.

    Does it have to do with the shape of the model? It looks like this from a side view: /````` (pretend the apostrophes are straight lines.)

    Leave a comment:


  • replied
    First thing I'd suggest is setting it to block weapons and see if it collides with ordnance then.

    Leave a comment:

Working...
X