Announcement

Collapse
No announcement yet.

Shadows disappear after building lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shadows disappear after building lighting

    Hey, I've been working with modeling in 3ds Max and Zbrush for a little while, but just started to use UDK. I'm making a simple map, using the UTGame settings to run around in it. Before i build lighting the shadows look the way I want them, after building it seems like the light is diffused and no longer casts the diamond pattern from the window. Can anyone help me fix this?



    #2
    One of two things is probably happening. Either you don't have a high enough lightmap resolution for the meshes that the shadow is being castes on, or you're using the May 2012 version and the window is using a masked material which is bugged in that version and won't cast shadows.

    Comment


      #3
      It was the lightmap resolution. Thanks! Building the lighting took longer than usual though, only 5 min, but thats almost tripple what it was. Is this a normal amount of time? I have a lightmass importance volume set up in the area.

      Comment


        #4
        Yes, increasing the lightmap resolution will increase rendering time--5 minutes is nothing. The default resolution of 32 is way too low so increasing it will have a pretty big effect on your lighting build time.

        Comment


          #5
          Yeah 5 minutes is perfectly fine. Entire completed levels could take hours and hours. Once you have an entire level together building lights overnight while you sleep may become standard haha.

          Comment


            #6
            Thanks. I appreciate it. I finished working through a few tutorials and got used to hitting build all after I add something new. Now that im building my own level anything longer than a few minutes feels painfully long. haha.

            Comment

            Working...
            X