Announcement

Collapse
No announcement yet.

Help with Landscape Lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help with Landscape Lighting

    My lighting looks so terrible. The problem is, I don't even know where to start. In the picture below, the lighting for the landscape I'm using just looks choppy and disgusting. I'm using one dominant directional light that's attached to the skydome above. Is it a problem with the world properties? The landscape, or the light properties? Any thoughts as to where to proceed?


    #2
    These are self shadowing artifacts also known as shadow acne. This does occur because your lighting is dynamic. Just rebuild your light and everything looks good.

    If you want to use full dynamic lighting for a specific reason, you should use a DominantDirectionalLightMoveable first. The problem of self shadowing artifacts will remain though. But it's possible to change some settings in the UDKengine.ini to improve the look.

    Comment


      #3
      Shadow acne will persists it just specific of how shadow mapping was implemented. Nothing can be do about it.
      But for better quality I suggest:
      1. Find LightComponent.uc in "install diir/Development/Engine/Src";
      2. Go to default properties.
      3. Look for ShadowProjectionTechnique.
      4. Change it value to ShadowProjTech_VSM.
      5. Rebuild you scripts.

      You can also try ShadowProjTech_BPCF_High
      But it didn't worked for me.

      Comment


        #4
        Thats not true, it's possible to change the shadow depth bias along with some other settings (like VSM,PCF shadows and shadow filter radius) in the .ini files. This does reduce shadow acne artifacts for sure:
        UDK default: http://www.abload.de/img/shadowacne1_depthbiasbdovb.png
        improved: http://www.abload.de/img/shadowacne1_depthbiasx4rqe.png

        Comment


          #5
          Originally posted by mAlkAv!An View Post
          Thats not true, it's possible to change the shadow depth bias along with some other settings (like VSM,PCF shadows and shadow filter radius) in the .ini files. This does reduce shadow acne artifacts for sure:
          UDK default: http://www.unrealed.info/forum/attac...0&d=1313405215
          improved: http://www.unrealed.info/forum/attac...9&d=1313405207
          Yes. And other problems will popup, like inaccurate shadows. Quickly disappearing shadows.
          I know I tried these setting, and I couldn't find anything that was good enough for higher and lower distances at the same time.
          My best option was change to VSM and play with light settings inside editor.

          Comment

          Working...
          X