Announcement

Collapse
No announcement yet.

Texture is blurred in shadow? Hulp.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Texture is blurred in shadow? Hulp.

    Does anyone have any idea why this happens?
    Click image for larger version

Name:	forumkuva.jpg
Views:	1
Size:	22.5 KB
ID:	3252588

    I think the problem is with the staticmesh, but I haven't been able to pinpoint it yet. Thus I'm asking you people. The snow mesh is just a regular staticmesh and the material works just fine until I build the lights. After that the shadowy area gets kinda blurred. I've tried looking trough mipmaps and lightmaps. The material also works on other meshes just fine, which led me to the conclusion that the material itself works just fine.

    The light is just udk basic dominantdirectional light. No special settings there.

    Also: Has anyone else had a problem when working with modular house pieces? The shadows sometimes get blurred altough the meshes are exactly the same and they are positioned side by side. ( So they are facing the same direction and all that jazz.) Also sometimes it looks like the shadows are "bleeding" from the sides so that the meshes get a dark outline.

    Anyone? Any guesses or thoughts?

    #2
    test to rebuild ligt or rebuild all.

    Comment


      #3
      I've done that too. Several times with different settings. Doesn't seem to affect it at all.

      Comment


        #4
        maby it's something with the udk itself. but i don't think so.

        Comment


          #5
          I personally think that the static mesh itself has something funny going on. I've tried to re-export and import it, but it doesn't seem to do anything either. : P

          Comment


            #6
            have you created the scene in 3ds max/maya/blender. as one static mesh?

            Comment


              #7
              No, only that particular snow area. It's one static mesh.

              Comment


                #8
                What is your lightmap resolution? By default it's 32, although I'd guess you've turned it up. It could be that it's still too small, but if the lightmap is already set to a reasonable size then perhaps your mesh is simply too large and needs to be split up into more pieces so that you can have more lightmap coverage.

                Comment


                  #9
                  Yep, I've done that too. I've tried some ridicilous figures for that value, but it doesn't fix my problem. You might be right about the size, I have to try that out. It just a bit weird since that isn't even the biggest mesh I've worked with but still this is the first time I have this kind of problem. Thanks for the input! : )

                  Comment


                    #10
                    I actually found an solution for half of my problems! Solution for the modular bleeding http://www.worldofleveldesign.com/ca...-and-seams.php The blurring is still a huge mystery though.

                    Comment

                    Working...
                    X