Announcement

Collapse
No announcement yet.

Foliage causing massive lag

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Foliage causing massive lag

    I am currently in an isometric camera view (top down on my character).

    If I use foliage to test paint some grass on the ground, I start getting frame rate drops from 80 to 30-40 and major twitches in editor mode.

    If I use the same amount or MORE of regular static meshes of that same grass copy pasted over and over, it causes no lag.

    Any idea?

    #2
    Foliage is very performance intensive, you'll have to do some sacrifices if you want to use a lot of it.

    At least make sure it's not very dense and that the pop-in distance isn't too far away (can't remember what it is specifically called at the moment).

    Comment


      #3
      For to use foliage choose trees from speedtree compileds, they are very otmized for udk, dont use foliage by fbx or others

      Comment


        #4
        Seriously read up as much as you can on lod and massive lod. You can implement speedtree-like performance saving means,like having multiple meshes be replaced by a single billboard that always faces the camera at a distance. Lots of foliage CAN work, just not "out if the box".

        Comment


          #5
          It all depends on the poly count of the grass model to begin with. You want your model to be 100 tris or less to use it well. Take a look at my tutorial on this on my website or youtube page...

          Comment

          Working...
          X