Announcement

Collapse
No announcement yet.

InstancedFoliageActor + Landscaoe shadow issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    InstancedFoliageActor + Landscaoe shadow issues

    Hi everyone,

    I'm fairly new to the forums, but have been using UDK for quite some time. I mainly used it for interior environments, but recently, I thought I'd try my hand at an exterior environment with some foliage. I searched the forums and have yet to find a conclusive answer. I have created a landscape and painted some foliage meshes using the foliage tool. All meshes and textures appear correctly. However, when I bake my lighting, I have small shadows on the ground caused by my grass planes. My question is as follows : How do I prevent the grass from casting shadows on my landscape without preventing it from recieving shadows from other meshes ? My lighting is pretty much a default UDK Mid Day lighting set up to used cascaded shadow maps and my foliage materials are 2 sided MLM_Customlit materials.



    Thanks for the help !

    Edit : Picture is up. I don't want the grass to cast shadows for 2 reasons :
    1) The shadows accentuate the junction of the grass plane and the landscape, making it easier to see the planes
    2) When I get far away, the cascaded shadow maps kick in making everything pretty much black...

    #2
    Well, I figured it out. It might be a cheap kind of 'plan b' solution, but if you uncheck 'cast shadows' directly in the mesh settings (the place where you set your lightmap size, texture, etc.), shadows will NOT be cast, no matter what type of actor it becomes (instancedfoliage, interactive foliage, static mesh, etc.).

    Comment


      #3
      How exactly U does to get this result? My grass always looks like this:


      I already played with shadows, Transmission and even translucent.

      Can u pack Your UPK and post here?

      Comment

      Working...
      X