Announcement

Collapse
No announcement yet.

Clean LightmapUV but artifact with Lightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Clean LightmapUV but artifact with Lightmass

    Hi, I noticed an annoying issue on lightmap which occurs only when using lightmass, even with production quality setting.
    The result looks like what happens with too small padding between UV chunks or very low lightmap res except my UV are clean according to UDN documentation and lightmap res is large enough as I have no artefact when using classic lightening on my objects.

    The pics below show an example on a simple cube, you can see the weird dark line on some face borders. I have the same problem on all my others models, actually it also happens on UDK objects...

    So is there something to do in lightmass settings or have I to deal with this inaccuracy?




    #2
    What lightmass settings are you running?

    Also this may be one of those things your looking to much into, I would say make a complete asset and then look at it.

    Comment


      #3
      Are you asking for the quality setting? If yes read my post else tell me which settings but I think I let everything to default.
      I made more complex assets, same result, as I wrote in my post...

      Comment


        #4
        Honestly not sure how to fix it than, sorry I cannot be more help. If you find a solution post it

        Comment


          #5
          It depends on your edge placement, if it doesn't line up with the pixels there can be some edge bleeding. You need to try and make it so that you use as much space as possible, and that you use the lowest amount of seams as possible.

          Comment


            #6
            The problem is the layout of your lightmap UVs, using the UDK unwrapper is not always a good solution.

            Have a look at this http://udn.epicgames.com/Three/LightMapUnwrapping.html and set your lightmaps up like the author does in the last example with the boxes, that is join the side facing faces of your mesh together in the UVMap so they're treated as one contiguous face - this will fix your lightmap seam.

            Comment


              #7
              I tried a lot of UV placement variations without better result. As my models are very angular I can't unfortunately reduce more the amount of seams. What is very annoying is the fact that the lightmaps have no problem when not using lightmass... I think it's just a lightmass UV packing limitation, usually textures hide this issue but it would be nice to fix it.
              Anyway if someone have an idea, please share your thoughts.

              Comment


                #8
                look i have the same thing, i have bleeding aswell.
                http://forums.epicgames.com/threads/...w-(-(Lightmaps)

                If you can try to disable ambient occlusion in the view-world propperties.
                My bleeding gets reduced allot when i disable it.

                Comment


                  #9
                  Year I saw your post but the problem doesn't seem to be the same, having AO turned on or off in my lightmass settings doesn't make any changes on the issue.

                  Comment


                    #10
                    Originally posted by darthviper107 View Post
                    It depends on your edge placement, if it doesn't line up with the pixels there can be some edge bleeding...
                    You were right, moving the "problematic" edges by one texel usually fix the dark lines but you have to be sure about the lightmap resolution because when changing it, new dark lines appear on others edges...

                    Comment


                      #11
                      I have had similar issues, and thought I had fixed it by separating each face and giving them lots of UV space around them but I think I just got lucky. I don't understand how you can make sure the lines are on pixels in the UV editor (for me in 3DS Max), is there some way of setting up a snap to grid for it?

                      Comment


                        #12
                        There is indeed a snap option and a customizable grid in max UV editor, the snap button is on the bottom right corner and the grid size can be set in Option>preferences window.
                        However, snapping will not necessary give the best result, it's better to don't put the poly uv edges exactly on the pixel edges...

                        My advice, assign a checker map on your mesh with a tiling corresponding to the lightmap resolution and display it in the UV editor by choosing your map in the scrolling menu in the tool bar.

                        I realize I should have posted this topic in the modelling section...

                        Comment


                          #13
                          try a lower lightmap res, if the edge of one of your faces on the uv layout hits the middle of a pixel then you can get that effect.

                          Comment

                          Working...
                          X