Announcement

Collapse
No announcement yet.

Shadow Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shadow Problems

    Hey,
    So I've been working with UDK for the past year and I've mainly been doing small tests to make sure everything works how I need it and just to learn about the engine. This whole time I have had this problem but I never found it to be an issue for what I'm working on until now. When I create a map from one of the templates I can see the shadows for object is nice and light, as seen here:

    (uses a default speed tree mesh compiled at "Medium" light quality with light mass for testing purposes)

    click HERE if image does not load

    But when I create a new map from scratch and load the same object and put a lightmassimportancevolume around it (I know I'm missing something there) I get pure black shadows, even without the volume, as you can see here:

    (uses a default speed tree mesh compiled at "Medium" light quality with light mass for testing purposes)

    click HERE if image does not load

    Any help to this problem of mine would be greatly appreciated.

    Thanks,
    - Dr3d

    #2
    shadow map resolution for the floor is too low. And what light are you using?

    Comment


      #3
      Well the template uses a model for the ground. I wont be using BSP, so i'm not worried about the quality of the cast shadow in the test, that will change on the final product. I'm using a dominant directional light. I just want the shadow to not be pitch black and look more like a real, faded, shadow like in the template.

      Comment


        #4
        View - World Properties

        Under Lightmass change the Environment Color.

        Comment


          #5
          Thank you taz for the help. That worked perfectly.

          Comment

          Working...
          X