Announcement

Collapse
No announcement yet.

TextureRenderTarget2D no skybox, help to turn it ON?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    TextureRenderTarget2D no skybox, help to turn it ON?

    I'm everybody, I'm a new to UDK, so sorry if this question is stupid)

    Here is my problem, i'm rendering a scene to the 2d texture using TextureRenderTarget2D and SceneCapture2DActor, but without skybox, it's black... Don't know how to turn it on. Help me please, i have very small period of time to fix this.

    TextureRenderTarget2D format is A8R8G8B8. I need to get the render quality as the main camera if it's possible.

    #2
    may be i need to post this question to another branch of this forum to get the help?

    Comment


      #3
      change the far plane in the SceneCapture2DActor properties.

      Comment


        #4
        Thank you so much... it was the easies parameter to try but i checked all of the other stuff exept this... made it 2000 to see all the level but for skybox 200000 was needed)

        But one issue left, there is no AA in the capture and all the geometry edges is very rough. May be you or somebody knows where i can turn it on?

        Comment


          #5
          You need to be running in DirectX 11 features enabled to see anti-aliasing at present.

          Comment


            #6
            There is regular Post Process AA which does not require DX11.

            Comment


              #7
              I'm running on DX11. But there is no AA on capture. But all is OK with regular player camera, all is smooth in it.

              Comment


                #8
                The captured stuff should be antialiased when the whole seen is anti-aliased?

                Comment


                  #9
                  I think it's not connected because main view is performing through player's camera(and it's well antialiased) and capturing is performing through another Actor, and then this live capture is used as a texture on material. This Material is drawn on the HUD via Kismet. I checked all the options and parameters in all these levels(capture actor, texture, material, Kismet draw HUD node).... May be i missed something?

                  Comment


                    #10
                    Here is creenshot, as you can see it's DX11. There is AA on player camera but there is NO AA on capture (you need to save it and watch it in full resolution)

                    Comment


                      #11
                      I believe having anti-aliased texture render targer is impossible. Unless you render at some really ridiculously big resolution and then shrink it down.

                      Comment


                        #12
                        Why are you think so? There is no texture AA in UDK or the problem is something else?

                        Comment

                        Working...
                        X