Announcement

Collapse
No announcement yet.

Motion Blur In Foreground Layer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Motion Blur In Foreground Layer

    hi every one.
    i'm working on a FPS game and in order to prevent the gun from entering walls, i have to change the rendering priority group of it's skeletal mesh to Foreground instead of world. the problem is that now I miss some post process effects like motion blur, radial blur and lightshaft.
    i checked velocity buffer with VisualizeTexture console command and there's no velocity for gun's mesh in foreground mode.
    since there is no motion blur's for gun's mesh in UT, i'm a little confused, because i need to have these effects on my gun mesh.
    actually i don't know why but luckily DOF works fine in this mode
    somehow, one of these problems must be solved: entering the gun's mesh into walls or PPEs on foreground objects.
    thanx

    #2
    any body? somebody?
    can someone tell me how to disable PPEs like motion blur for some specific object in world layer?
    please help

    Comment


      #3
      I'm sorry, I have no idea but I'm interested too.

      Comment


        #4
        Are you not using the default first person setup for UT where the weapon is already set to be in the foreground? I think motion blur works for that, else I don't think there is a way unless you do true first person. If that's what you doing You will still have some trouble with the gun going through walls. However, default FPS style shouldn't have weapons going through walls.

        Comment


          #5
          Originally posted by TheAgent View Post
          Are you not using the default first person setup for UT where the weapon is already set to be in the foreground? I think motion blur works for that, else I don't think there is a way unless you do true first person. If that's what you doing You will still have some trouble with the gun going through walls. However, default FPS style shouldn't have weapons going through walls.
          thanx, but as i said, there's no motion blurs in UT.

          Comment


            #6
            Setting your gun to foreground is not preventing it to go inside the walls it is just making your gun be rendered over the walls (it is still inside the wall). The best thing you can do is to set your gun to "world" and setup propper collisions for your first-person gun mesh.

            Comment


              #7
              Originally posted by Matheus Martino View Post
              Setting your gun to foreground is not preventing it to go inside the walls it is just making your gun be rendered over the walls (it is still inside the wall). The best thing you can do is to set your gun to "world" and setup propper collisions for your first-person gun mesh.
              i know that by setting the gun to foreground mode, it still goes into the wall, but as much as i know, almost all FPS games are doing this, otherwise you could never get close to the walls in this games for opening doors, picking up items, etc.

              Comment

              Working...
              X