Announcement

Collapse
No announcement yet.

Avoiding player go through a static mesh

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Avoiding player go through a static mesh

    I'm modelling a chair and put some custom collisions.



    However when I test the map, the player can go through into the static mesh. It's like the chair has no solidity. How do I avoiding this without re-modelling collisions?

    EDIT: I put a high number on Mass properties but didn't worked .

    #2
    Did you save the package the mesh is in before testing?

    Comment


      #3
      Yes, of course.
      Even using Auto convex collision the result is identical.

      Instead, projectiles react fine with the chair.
      Just a question: collisions block ALL projectiles too?

      Comment


        #4
        Hmm, another thing to try is checking your collision settings, in the static mesh-editor. Not really sure what settings you should change, but look for Simple Box/Line Collision, try a few combinations, maybe it will work :P

        Comment


          #5
          All three collision types are checked.

          Comment


            #6
            Changed it to block all?

            Comment


              #7
              I'd need to actually work with the mesh to give you an idea of what is wrong, but I'd like to suggest maybe a simpler collision mesh? The player isn't actually sitting on the chair so why not just apply a box collision to it?

              Comment


                #8
                Hi, go to edit using static mesh actor > Collision > Click 6 DOP simplified collision. That should works

                Comment

                Working...
                X