Announcement

Collapse
No announcement yet.

max units to udk units

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    max units to udk units

    hey people,
    sinds i am using 3dsmax to create me meshes, i was wondering how i dan setup my export(or import at UDK) so it doesnt change the overall size of my model....

    currently i have my max settings set to "meters". now i have created a generator whit an overall height of 26,5 meter, BUT if i import it to UDK and i test play it, it appears to be only half that size.

    so how can i fix this?

    my regarts

    #2
    One whatever unit in Max = One unreal unit in UDK.

    Comment


      #3
      Rather than setting Max to any real world units, set it to Generic Units. This way you can have 1 unit = 1 UnrealUnit. If you are using FBX to transfer content, then make sure to leave it on Automatic for units.

      Comment


        #4
        But default pawn in UDK is 96UU. Meaning if you build everything to scale in cm and bring it in, everything will be huge. Building to scale in feet or inch will be off even more. Many consider 2cm = 1uu but this makes the default pawn 192cm. Very tall human. Create your own scale factor that works for you. I personally use 2cm = 1.2uu.

        Comment


          #5
          tried it but still after exporting it whit generic units and imported again didnt work... and i didnt find the automatic thing... i am using max 2009

          Comment


            #6
            but isnt there a way to export from max in meters, and import it to any unit in UDK and still the mesh has it sizes?

            Comment


              #7
              Whatever unit you set in Max, one is equal to one UU. If you set it to meters, 1m = 1uu. If you set it to inch, 1inch = 1uu. Using this, you need to come up with your own formula. There's no automatic unit conversion as far as I'm aware. And remember that default pawn size of 96uu. Because size is in relation to your pawn.

              Comment


                #8
                and where can i set that?

                Comment


                  #9
                  Originally posted by Erabus Von Gott View Post
                  and where can i set that?
                  Set what? Units in Max?

                  Comment


                    #10
                    where can i set that one max unit will be (for exsample) 2uu?

                    Comment


                      #11
                      You cannot change unit settings in UDK. You have to change it in Max. This is what I do. I build everything to scale in cm. Before exporting, I scale it down 0.6 then export.

                      Comment


                        #12
                        What I do (I use Maya but I'm sure this applies to Max as well) is create a cube in Maya with 32 x 32 length and width and 96 height and use this as a representation of the player scale, then model appropriately, deleting the cube once I'm ready to export.

                        Comment


                          #13
                          are you sure it was scaling down? i tried, but gues what, it was even smaller ...

                          Comment


                            #14
                            pardon me... i got the sollution for my workflow

                            *dont scale
                            *go to export and use FBX
                            * go to advanced options > units and set to centimeters (if you worked whit meters like me)

                            and voila, it worked

                            Comment


                              #15
                              oh before i forget...

                              THX ANYWAY

                              Comment

                              Working...
                              X