Announcement

Collapse
No announcement yet.

Help please.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help please.

    After creating a level and adding cinematic's i jumped in UDK Game and tested it and found this very annoying grey that represent's anything in the background mid range of the camera, at a vast distance its pretty normal, i am using a height fog, with several postprocess volumes which have bloom and dof enabled with a bit of colour grading, this only happens in UDK Game, in the editor its how i want it to be aswell as the "editor in-game window mode" i am using no directional lighting, though i am using the 2010-12 version as i started this portfolio early this year, some assistance as to how to fix this problem would be greatly appreciated. Thanks in advance

    [SHOT]http://img405.imageshack.us/img405/7926/problemet.jpg[/SHOT]

    #2
    The 'bug' is actually the Fog working fine.

    What's really going on is that you probably don't have any mesh objects in the background. Fog errors out in that special case, returning black (&, if you don't have a sky-dome, you'd probably never see a diference...).

    Throw some BSP back there to check...

    Comment


      #3
      what you see in the background are bsp's, i originally had building static meshes and it was the same, so i deleted them, also there is no skydome as it radiates too much light and gives off a artificial feel to a night time scenario

      the fog density is 0.000500

      these are my postprocess volume settings

      Comment


        #4
        The pitch black "sky" behind the rain in the extreme UL and UR corners are bsp? What material?

        Comment


          #5
          sorry, the pitch black is actually empty space, the grey area's are bsp.

          Comment


            #6
            OK, right. Again, HightFog errors when there is Null Space behind it. You need either a Huge Additive BSP with a slightly smaller Subractive BSP cube inside it.. or a sphere mesh with normals facing inwards. Assign the RemoveSurfaceMaterial to them (this is a flat black so it won't interfere with bounced lighting), and set the Lightmap settings [F5] as follows: For BSP, set Lightmap Resolution to 65536, for static meshes set LM res to 8 or 4. Then you'll be able to see what your 'furthest fog' really looks like and tweak the settings down from there...

            Comment


              #7
              Thank you very much Joshua, i will try it right now

              Comment

              Working...
              X