Announcement

Collapse
No announcement yet.

Opacity/alpha drawing order problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Opacity/alpha drawing order problem

    Hi,

    I have this opacity/alpha drawing order problem or some sort of flickering when looking at my window mesh at different angles.

    The Ocean materials seems to pop right through it at times where the opacity of the glass seems to go completely transparent. It happens in game/play mod too.

    I'm wondering if there is a simple fix here or anyway i could fix it. It seems to only happen when the two opacity maps overlap, if I set one to Opaque blending it stops.

    I have tried fiddling with two-sides on/off, Tried all different blend modes and lighting model setting but nothing seems to stop it.

    Anyway here are the photos...




    #2
    Ok after breaking down my whole scene and play with many settings I found the fix for this, Happens to have been a simple fix after all!

    Don't you hate it when one tickbox breaks your scene?

    For anyone else that may have similar problems this is what worked for me.

    Went into my Glass Material Properties under D3D11 settings I enabled "Enable Seperate Translucency" !!!

    Comment


      #3
      Your windows don't use the distortion channel by chance do they? I found that causes the issue, I had no idea there was a fix. lol Thanks

      Comment


        #4
        Actually I did have some disortion effect going on that channel as seen in the photos but I tested the Scene with No channels just plain black transparent materials and I still had the problem so I figured it wasnt down to the way materials were setup but something to do with materials overlaying each other.

        Comment


          #5
          Its a simple fix, no material work necessary. Select the ocean mesh, goto it's properties, under the rendering tab of the mesh, look for translucent sorting value, by default it should be set to 0. Set it to -1. Or give the windows a property of +1 either way, you'll have to give the windows a higher sorting priority value inorder to fix it. And that is all you need to do.

          Comment


            #6
            Originally posted by Havoc89 View Post
            Its a simple fix, no material work necessary. Select the ocean mesh, goto it's properties, under the rendering tab of the mesh, look for translucent sorting value, by default it should be set to 0. Set it to -1. Or give the windows a property of +1 either way, you'll have to give the windows a higher sorting priority value inorder to fix it. And that is all you need to do.
            Thanks! This helped me with a similar translucency problem.

            Comment

            Working...
            X