Announcement

Collapse
No announcement yet.

Lighting Causing Chaos [FIXED]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lighting Causing Chaos [FIXED]

    I'm having problems with lighting, and have tried everything to fix it. From material settings to static mesh and lighting properties, I cannot find a solution. Please help me out here, it's driving me nutz.




    (FIXED)


    1. My first problem is the lighting in the first picture; it doesn’t fade the way normal lighting would. I'm not sure if I have to redo the model or if it's an engine/lighting/shader issue. Nevertheless, if I redo the model the textures would come out in a lousier resolution.
    2. My second picture shows the static mesh not accepting the spot light. I again have tried hours along with others to identify the problem. I have even exported and redone the model over and over again.


    In the previous UDK, there were no problems with the lighting, and ever since this lightmass feature was introduced, it has been the biggest spender of my time. In possible, please help me find a solution to my ongoing nightmare. Thank you.

    #2
    Fix your image tags

    Comment


      #3
      Problem number 2 fixed!

      http://forums.epicgames.com/showthre...5#post28236355

      "That looks like a normals issue. In 3ds max, select all the faces of the object, go to smoothing groups, set it to 0 degrees and hit auto smooth groups. Export that mesh, which should now be hard edged, into the UDK and rebuild your lighting. I am assuming the mesh already has good lightmap UVs. That should fix your problem.

      Basically, Unreal is thinking that the edges of the mesh are smooth, so it interpolates the lighting and shadows to gradient and enhances those features. However, they should be hard, as they are a flat surface with a 90 degree angle. The only time you want smooth edges is on a rounded surface setup."



      It has been acouple hours now, and i'm still trying to find a solution. This thread helped me fix my second picture; however, I'm still having problems with the first picture. The no light falloff is still a pain in the gas tank.

      Comment


        #4
        Now, my second problem is the same as the first one. >:I
        If anyone has a solution please let me know, I would greatly appreciate it. Thank you.

        Comment


          #5
          I'm guessing you don't have high enough light map resolution

          Comment


            #6
            Second that, I had the same problem, in the static mesh properties, you will find lightmap resolution, change it to a higher power of two value.

            Warning: This will mean **** all if you dont have a second uv channel for the mesh and/or it sucks.

            Comment


              #7
              I thank you for telling me. I didn't try setting the lightmap resolution into powers of two.
              I wish I could give you a hug right now. It was the solution I have been trying to figure out for the entire day. Thank you.

              There was a trick, my second UV came out weird and changed the first UV somehow; however, I easily took care of it by doing the first UV and re- editing into an editable poly and redoing the exhisting UV then adding the second UV. This miraculously worked.

              Here's a tutorial I found on the matter; however, it was of not of relative importance. http://www.youtube.com/watch?v=bbdOpuKqGaQ
              (It's for those wanting to know how to make second UVs)

              Comment


                #8
                Here is the result:


                Time with this problem: 14 days.
                Time spent finding a solution: 15 hours.

                I started by unwrapping the model, re-editing to an editable poly, and re-unwraping it. I added a sencond UV channed and expoted it. I imported the model into UDKand set the
                light map resolution to 512. The result worked and the lights affect the model perfectly. (for those with similar problems)

                Now I can go back to creating content and worry less when other similar problems arrises.

                Maybe the Unreal developers should address this confusion in finding a solution. Since there are so many others with the same problem.
                Thank you for helping me sergeantgarbage, your effort is appreciated!

                Comment

                Working...
                X