Announcement

Collapse
No announcement yet.

Particle Emitters constantly being drawn.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Particle Emitters constantly being drawn.

    Hi, had a search on the forums for this issue but nothing came up also asked around in some of the UDK IRC chatrooms but no luck.

    The problem I'm having is that no matter what distance I am from a particle emitter they won't get culled. I'm using a simple emitter to create a fire effect on a torch, nothing fancy. I've checked the Allow Cull Distance Volume box and applied a Cull Distance Volume around the emitters, but nothing. All the static meshes around them get culled as expected but not the emitter. As you can imagine with a few of these around the level it's really impacting performance.

    Anyone know of something simple I might have missed or another culling method that might work.

    For now I've had to remove the fire effect from the level, which isn't ideal. Would be great to get it back in there.

    Cheers.

    #2
    You might try Draw Distance in the rendering properties and/or use a trigger to toggle the particle on/off via kismet when the player enters the visible area

    Comment


      #3
      Originally posted by Max Power View Post
      You might try Draw Distance in the rendering properties and/or use a trigger to toggle the particle on/off via kismet when the player enters the visible area
      Ahhh yes. Just ran a few tests and it looks like manually setting the Draw Distance works.

      Thanks a lot for the help Max Power, much appreciated.

      Comment

      Working...
      X