Announcement

Collapse
No announcement yet.

Normal map problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Normal map problem

    Hello,

    For the first time i made a character in 3dsmax and then made normal maps
    etc by making a high poly mesh with zbrush everything worked perfectly till
    I import my model in UDK.

    It looks good except on places where i splitted the mesh for the uvw map,
    the biggest problem is on the hand. It looks like its different object even
    though there welded together in max. The problem appears when i add my
    normal map to the material.

    There is no problem what so ever with the flow of the normal map from one
    part to the other. It is all straight from zbrush and when i render in max it
    doesnt have this problem as you can see on the right of my screenshot.

    So i dont know why its looking like the mesh is not connected even though
    its welded and the normal maps is correct. They are only separated in the
    uvw map but as you can see on the screenshot in 3dsmax the normal map
    on the different parts is connected well.

    Plz scroll to the right to see everything also the max renders.


    EDIT: just to be clear i though it could be the specular but thats not the problem its only when applying the nromal map in UDK


    #2
    have u tried inverting the green channel?

    Comment


      #3
      Correct me if i am wrong. i think you are supposed to put the "normal bump" map in ur bump map slot and put ur normal map in the normal map slot of the normal bump. (3ds max)

      Comment


        #4
        EDIT: sorry u said inverting but i dont know exactly what you mean with that

        About 3dsmax you where right i never used normal maps in 3dsmax so i didnt know, but that only made it look better and not like it looks in udk

        Comment


          #5
          i didnt mean use only the green channel, i meant invert the green channel of ur normal map. Go to photoshop and select the green channel and hit ctrl+I and save it. then plug in the rgb of this normal map into the normal node slot in the material editor (udk).

          Comment


            #6
            Originally posted by HypnoticShark View Post
            i didnt mean use only the green channel, i meant invert the green channel of ur normal map. Go to photoshop and select the green channel and hit ctrl+I and save it. then plug in the rgb of this normal map into the normal node slot in the material editor (udk).
            Ah ok ill give it a try

            Comment


              #7
              cool, lemme know how it goes

              Comment


                #8
                Still the same problem if i invert the green channel, the normal map changes but the problem i had stays the same

                Comment


                  #9
                  if u dont mind can i have a look at ur mesh and normal map? i have sent u a pm

                  Comment


                    #10
                    while importing your normal map, set ur compression settings to either TC_NormalMap or TC_NormalMapUncompressed. Otherwise your normals wont show up correctly, hope that solves it

                    Comment


                      #11
                      Originally posted by HypnoticShark View Post
                      while importing your normal map, set ur compression settings to either TC_NormalMap or TC_NormalMapUncompressed. Otherwise your normals wont show up correctly, hope that solves it
                      It solved the problem thanks again

                      Comment

                      Working...
                      X