No announcement yet.

Shadow from brushes

  • Filter
  • Time
  • Show
Clear All
new posts

    Shadow from brushes

    Hi all from Russia !
    Why when i use lightmass param ON to compil my lighton the level, all brushes don't cast shadows? How fix it?

    It's a very annoying bug!

    Originally posted by Kilgariff View Post
    I can confirm that the bug is related to BSP properties as opposed to lightmass itself.

    Steps to reproduce:
    Create a BSP surface using the cube primitive builder brush
    Select surface
    Press F4 to view the properties

    Most surfaces have these initial settings, despite them not being defaults:

    Object.LightmassSettings.bUseTwoSidedLighting True
    Object.LightmassSettings.bShadowIndirectOnly True
    Object.LightmassSettings.FullyOccludedSamplesFract ion 0.000000

    Occasionally, there are insanely high (or low, negative) bogus values.

    @Froyok: For now, you should be able to fix it by pressing SHIFT+S to select all surfaces, F4 for properties, then right click on each property and click "Reset to default"