Announcement

Collapse
No announcement yet.

Why such a difference in terrain shadows or static mesh.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why such a difference in terrain shadows or static mesh.

    I noticed when i have static mesh the shadows from the same lightsource appear different then on my terrain. Checked alot of settings but cant get it fixed... Does it have todo with my Dominant Directional light?

    Left is terrain right is my static mesh..


    #2
    If you want better shadows on your terrain you have to select Is Overriding Light Resolution and increase the static lighting resolution above the option in the terrain lighting options. Increasing the number has effects on how long it takes to build the lighting in your scene.

    Comment


      #3
      Thanks anyway, but my terrain is the one with the good shadows, its my static mesh showing the low resolution kinda shadows. My terrains shadows are sharp as hell

      So that doesnt really solve it

      Comment


        #4
        Another thing: you don't want to change the DetailMode of the Terrain/Mesh. The DetailMode tells the engine on what system settings the mesh should be rendered at all. If it's set to High, the mesh will only be rendered if the user has the WorldDetail settings at least on High as well, while Low will make it always be rendered for the user. The setting is only recommended to be changed for stuff that are purely visual bonus and not supposed to collide or interact with the player or projectiles in any way.

        Comment


          #5
          Hmm ok, didn't know what it was used for and didn't even notice i chenged it hehe but thanks for the info thats kinda important.

          Anyone has an idea on my shadows?

          Comment


            #6
            *Bump*

            Anyone having any idea??? I really can't find why my mesh shadows are so low resolution compared to the sharp shadows on my terrain, and it doesn't look pretty

            Comment


              #7
              If I'm wrong, correct me, but I think you can change the lightmap-resolution in the staticmesh-editor. IIRC, lower numbers = higher resolution.

              Comment


                #8
                Originally posted by mktwo View Post
                If I'm wrong, correct me, but I think you can change the lightmap-resolution in the staticmesh-editor. IIRC, lower numbers = higher resolution.
                No. For static meshes higher number means higher resolution. Same for terrain. For BSP, higher number = lower resolution.
                How high the lightmap resolution for your static mesh is?

                Comment


                  #9
                  Oops, guess I got those mixed up then, sorry

                  Comment


                    #10
                    Hmm well i remember putting it on 4 by making the same mistake as mktwo...
                    But before i did that i already had the problem but let me check and come back to you.
                    Thanks for responding anyway both of you!

                    EDIT:

                    Tryed it with Light Map Resolution of 100, i had the idea my building took alot longer but still nothing changed.... weird

                    Comment


                      #11
                      I could be wrong here, but I you might need to use powers of 2, so try setting it at 256 or 512, if that's not any better, try 1024 ;D

                      Comment


                        #12
                        Hmm, thanks i tryed but it's like 0% difference with putting it on 1. so i dont know whats happening here...

                        Comment


                          #13
                          Right now im trying to give my mesh a material, give it uvw and export it with max in stead of maya.... just seeing if it changes anything

                          Comment


                            #14
                            I think it has something todo with my light/terrain. I now changed my textures on both terrain and my mesh to the same material. And when i render now my mesh shadow is still not sharp, but it looks alot better. I even like my mesh shadow more then my terrain shadow now.

                            I used a DominantDirectionalLight, but when i change my light to a normal light, both shadows will be the same, and they will be the way the shadows where on my mesh, not as sharp as on my terrain!

                            So i think it had something todo with my settings on my Dominant light in combination with my terrain... cant find out what exactly but changed to a normal light now.

                            Comment

                            Working...
                            X