Announcement

Collapse
No announcement yet.

Meshes & Materials not working in UDK Game

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Meshes & Materials not working in UDK Game

    Greeting UDK community,

    I teach a level design workshop at a local university and recently we switched from the UT3 editor to the UDK editor. This class is only two days so we do not get into creating custom meshes; however, I was able to find a tutorial that showed how to copy the materials from UT3 into the UDK. Now we are not using this for commercial use, it is for educational use.

    My problem is this, when I test the levels in the UDK editor, the materials (on both csg brush surfaces and meshes) from UT3 work fine, but in the actual game, they do not work or crash the game. Is there a way to fix this for the judging of the levels we want to play test the students levels.

    Thanks for the help.

    #2
    There are a few things you can check. First is that if the material has its "bUsedFor" booleans checked right. Make sure the material has the checkboxes set for what its being used on in the scene. Then make sure a shader cache is being saved, delete your local shader cache then re run the editor and have it re compile shaders. This can take a loooong time. Over 30 minutes in some cases.

    Comment


      #3
      Originally posted by badkangaroo View Post
      There are a few things you can check. First is that if the material has its "bUsedFor" booleans checked right. Make sure the material has the checkboxes set for what its being used on in the scene. Then make sure a shader cache is being saved, delete your local shader cache then re run the editor and have it re compile shaders. This can take a loooong time. Over 30 minutes in some cases.
      This is going to sound noobish, but how do I save the Shaders and then recompile them? The other issue I ran into was the default materials, ones that came with the UDK, do not appear in the game either.

      Thanks for the quick response.

      Comment

      Working...
      X