Announcement

Collapse
No announcement yet.

[SOLVED]Scene Depth not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED]Scene Depth not working

    so i been following this example just to check scene depth however it doesnt seem to work at all? im using the November Beta

    Any suggestions would be awesome. i copied everything to the exact.

    http://udn.epicgames.com/Three/Mater...tml#SceneDepth

    #2
    Works fine for me (tried in December build, BLEND_Translucent, MLM_Unlit). Maybe you forgot to attach it as a material effect in the post process chain?

    [shot]http://img809.imageshack.us/img809/769/scenedepth.jpg[/shot]

    Comment


      #3
      its in my post process chain, i see the effect but there is no depth working.

      pixel depth and dest depth work fine : [ i have it all set to translucent and Unlit

      Comment


        #4
        I tried it now in November build too and it works there too. Only thing I can think of is that maybe you don't have checked show in game/editor option in Material Effect or Post Process applied to the map (though unlikely that this is the case). Besides that I really can't think of any reason why it wouldn't work.

        When you said you see the effect, did you mean for Pixel and DestDepth?

        Comment


          #5
          i see the scene texture sample doing its thing taking th ecolor effect but the scene depth node doesnt make the transition like in the example you showed me, im trying to lerp in between two colors in the scene. i know it works because i tried it in pixel depth, on a box. and when u get far from it the colors blend in correctly. However when i plug in the scene depth instead, it does nothing. would you like to see my package incase i did something wrong?

          i have it all set up in my post process chain. as a material effect and all that good stuff. i see the colors in game view but i dont see any transition in the foreground or background it just stays in the orange default color.

          Comment


            #6
            I doubt that you did anything wrong, though I haven't worked with Lerp in, just used the same material from the Example, but still if it's not a problem I would like to see the package.

            Comment


              #7
              Ill send it in a minute, i used the same UT example did it exact and it didnt work thanks for the help ill edit this post with the link in a quick minute : ]

              Remember try it in the November version it could just be that my download is bad

              here we go: http://www.filefront.com/17770634/GearPostProcess.rar

              Comment


                #8
                If I'm getting your idea right it looks to me that it's working properly and that color are blended. I only changed constant that goes to Divide to 4096, and bypassed that Add with -0.01 (not sure what it should do). To make example better to show, I just switched Alpha for those 2 lerps up there to 1 because lower settings kill color a lot.
                Is this the effect you wanted, one color for foreground and one for background?

                [shot]http://img41.imageshack.us/img41/7132/scndepth1.jpg[/shot]

                [shot]http://img833.imageshack.us/img833/5682/scndepthmat.jpg[/shot]

                EDIT:
                Yes, it's definitely working. Now I tried the same thing, just set 0 to both lerps to use ScreneTexture only, and in the Desaturisation node for background set 1 (kept 0.1 for foreground), and I got the same pic like in post #2. Forgot to mention that I used Dec build, I'll try now Nov build too.

                EDIT2:
                Works in Nov build too, just remove that constant -0.01 and add node, connect Divide directly to the Constant Clamp, I'm guessing that's causing the problem.

                Comment


                  #9
                  Yes that's exactly what i want, maybe ill just download december

                  obviously not such harsh colors but i get the idea. So any idea why it wouldn't work for me?

                  Comment


                    #10
                    Ok you know what it works now apparently i had to put the material node in the post process effect first, so i guess order matters in the post process chain.

                    Comment


                      #11
                      Looks like that was the case, node order does matter in post process. And it works with Add + constant (-0.01) too, my bad there.

                      Comment


                        #12
                        Thank you much for the help, i need to made specific effects you helped a lot : ] on to my shader creation!

                        Comment


                          #13
                          No problem.

                          Though I completely forgot about the node order, I always used Material Effect first, so never had problems with it.

                          Comment

                          Working...
                          X