Announcement

Collapse
No announcement yet.

Lighting / Shadow Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lighting / Shadow Problem

    Hello, I hope this is the right Forum to ask my question.

    I have a problem with the shadows cast by light sources.

    Here are two pics to make it clear:


    The shadow cast by the steel beams are only visible when the Point Light is selected. This is how it should look like ingame.



    When I deselect the Light the shadows disappear, like you can see it in this picture.
    How can I keep those shadows like in picture 1?

    Any help would be appreciated!

    Thanks
    .patient

    #2
    How does it look after a rebuild? Like pic 2 I guess? The shadows you see in the first pic are preview (dynamic) shadows, you are probably best off just getting some nice lightmapping going on the floor. Increase its lightmap quality/size.

    Comment


      #3
      Hello Hourences

      Thanks a lot for your fast answer.
      As you already figured out, it looks like pic 2 after the rebuild.

      But I think "lightmapping" is the right keyword for my solution!
      I even found the right tutorial for this on your Homepage

      I will try this out tomorrow!


      Thanks again

      Comment


        #4
        Having the exact same problem. Would be interested to hear your findings from this.

        Tried using the lightmapping tutorial on your site Hourences, but it doesn't seem to apply to bsp brushes, at least as far as I can see. Am i wrong?

        I *think* i remember that the lighting worked automatically when i tried udk for a little while about 6 months ago. I'll try installing old drivers and builds tomorrow to see if anything changes.

        I'm using a hd4850. .patient are u using an ati card by any chance?

        *edit*
        Ok. Installed the march 2010 build of udk and lightmapping works with just adding 2 bsp brushes and clicking 'build all', so it's not a graphic card issue. It did work as expected automatically in that build.

        Any advice anybody?

        Comment


          #5
          You're using the wrong lights, when you select a normal point light it enables lighting preview, if you want the dynamic shadows that it displays in your game you need to use pointlight movable actors or force dynamic in the flag tab.

          Comment


            #6
            Legend: i think this goes for .patient as well as myself. We don't want dynamic shadows. We want lightmapped shadows.

            In the march 2010 build and any recent tutorial videos i've watched you can create a simple level with just a couple of bsp brushes and a light and when you build all it will generate correct lightmapped shadows on the surfaces.

            The latest build (dec 2010) doesn't do this any more. As far as I can see this is either because of a bug, or because the default setup has changed and lightmapping has to be setup manually again as it appears used to be the case with unreal engine 3.

            Personally I suspect this to be a bug that has crept in as it seems unlikely the developers would make a previously user-friendly process require additional steps to implement.

            *edit*
            just to confirm that november's build also works correctly. As December's build just seems to add ios support then i would advise using november's build unless developing for mobile devices.

            So has a bug crept in, or have the default settings changed somewhere, eg. is it set up to render in vertex mode because it defaults to settings for developing on mobile devices?

            One more thing. On the 2 previous builds i've tested, each time i do a build all, windows firewall pops up asking whether to allow swarm to communicate with something, which i allow. The december build doesn't ask for permission so is there some communication not happening somewhere perhaps?

            Comment

            Working...
            X