Announcement

Collapse
No announcement yet.

Lightmass Time

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lightmass Time

    When I rebuild lighting in my level, the lightmass this last time took 3:21 minutes! Is there any way to reduce the time of lightmass without out removing it from building?

    #2
    Have you put a lightmass importance volume in?

    To put a lightmass importiance volume,Use the BSP Builder Brush, size it over the whole level. Then right click on the volume button and select Lightmass importance volume. Move the builder brush away, done!

    Hope this helps
    Team13

    Comment


      #3
      Originally posted by Team13 View Post
      Have you put a lightmass importance volume in?

      To put a lightmass importiance volume,Use the BSP Builder Brush, size it over the whole level. Then right click on the volume button and select Lightmass importance volume. Move the builder brush away, done!

      Hope this helps
      Team13
      Yes, I did already and it is still running slow, could it be speed trees, bsp, static meshes, or something?

      Comment


        #4
        How big is your level and what content is in it? And does that content have a high poly count?
        Also would you happen to have skydome/skybox in your level? As well as a dominant directional light?
        Team13

        Comment


          #5
          I've had it take up to half an hours before (while using an importance volume). I figured it was just because I had a bunch of polys in the same scene.

          Comment


            #6
            Well, yes I have a skydome and a directional light not domianant but the dome does not accept lights, but the map is about 5000 x 5000 units, it has like 308 static meshes, 250 of the meshes are foliage meshes, and i have 12 speedtrees, and 52 brushes

            Comment


              #7
              Go to View -> World Properties -> Lightmass

              Find an option called Static Lighting Level Scale. Increase this value to 2.0 or more. But this will decrease the quality of the lighting. Check out the results, if you don't like them set the value to 1.5. Play around with it and see what suits you best.

              Comment


                #8
                IT took 39 more seconds so IDK what to do I guess I could just wait for it to rebuild?

                Comment


                  #9
                  Don't worry just wait for the rebuild to complete with that option set to 2.0, or try 4.0.

                  Comment


                    #10
                    It had already but the time keeps increasing no matter what

                    Comment


                      #11
                      Your map took around 3 hours and 22 mins with the lighting scale set to 1.0. If you set it to 2.0 for example, it may be reduced to 2.5 hours, and you started the build only one hour ago... So don't expect it to finish now. If you want the build to finish really really quick, stop the build and set it to a higher value like 8. Watch how fast the build takes, if you don't like the speed, stop the build and increase the scale.

                      Edit: If that still doesn't help, maybe you have high resolution lightmaps set in your scene. Try to to do some optimizations. Override the lightmap resolution in static meshes which are not in a playable area (player can't notice details) and you could decrease the size of the importance volume to fit those areas only. Also, when a build completes, go through the reports generated. Find out which static mesh that had the most lighting percentage, and alter it's resolution.

                      Comment


                        #12
                        4 minutes but I don't want to lose the light detail

                        Comment


                          #13
                          Well, as I said you could play around with that option, it will control basically the trade-off of lighting build time vs quality. There isn't much you can do here apart from optimizing your level as I mentioned previously.

                          Comment


                            #14
                            Ok well I guess I wll do. That

                            Comment


                              #15
                              What's the resolution of the shadows you're trying to create? Have you tried to use modulated shadows instead?

                              Comment

                              Working...
                              X