Announcement

Collapse
No announcement yet.

Cannot see collision meshes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Those navmesh pylons are still a bit finicky... February 2011 build.

    Even on a completely flat BSP with 3 static meshes (my test level), it took some moving up and down of the pylon to get mine to work. But I'm grateful it does, navmesh beats dinkering around with pathnodes any day imho.

    Leave a comment:


  • replied
    Havent tried with later builds, still running with 09 here, but so far as terrain goes, i find that pylons like to be on as flat and as open a piece as you can find, then transform-> align to a 16 grid, then press 'end' to snap them to the floor.
    To speed up iterations on placement if they need tweaking still, shrink the mesh generation size right down to like 256uu so it will build really fast, and rebuild only that pylon until it works. After that you can bump up the mesh radius again and it will still work.
    Hope that helps some, anyway- I'm working on Battlefield sized maps here with little pain.

    Leave a comment:


  • replied
    Okay, so I figured out a workaround. I have deleted the ScoutClass and recompiled. Still didn't work. Attempting to use clean build with same solution, fixed it. However, it is still finicky. For those of you attempting to build on terrain, you may still get problems. I suggest you make sure that the Pylon Actor is close to 0 on the Z axis of the world position. I have now idea why this works, but it does. Oddly enough, it will build on the terrain even if the Pylon actor is below it.

    Through further testing, I had this same error in November. It seems as if it is just terrain that has problems. I am wondering if QA on terrain has started to fall, and instead they are trying to push landscapes asap.

    Leave a comment:


  • replied
    Originally posted by DragonSpawn View Post
    Really hope Epic has noticed this >_> Would hate for the issue to still be present in the next build.
    Agreed. Actually, I have to admit, I would laugh if Landscapes released without pylons working... then I would die on the inside. I would like to know if this is also a problem in the December source build. I am going to ask via the UDN mailing network. We have not switched to it at work, but it would be terrible it it had the same issues.

    Has anyone figured out a work around for this yet in the UDK, other than not switching to December and hoping that January has a fix? I attempted to delete the ScoutClass from the DefaultEngine.ini and recompile, didn't work (not sure why that would, but it was worth a shot).

    Leave a comment:


  • replied
    Ok I've deleted ScoutClassName=UTGame.UTScout and it still doesn't work for me. Is it working for anyone else?

    Leave a comment:


  • replied
    DefaultEngine.ini
    find
    [Engine.Engine]
    and delete this line:
    ScoutClassName=UTGame.UTScout

    and then full recompile!

    all tnx goes to Alex Newman

    Leave a comment:


  • replied
    Really hope Epic has noticed this >_> Would hate for the issue to still be present in the next build.

    Leave a comment:


  • replied
    This does not seem to be a problem in the Scout classes. I went as far as replacing the classes Scout and UTScout with Novembers' versions of the classes, but still no luck.

    Please Epic, fix this ASAP.

    Leave a comment:


  • replied
    yup, that's what i mean. It uses the parameters setup in UTScout (subclass of Scout) by default, for mesh generation.

    Looks like in October, the NavMeshGen_StartingHeightOffset was default 150, in December, it's default 72. Maybe tweaking that might help.

    Leave a comment:


  • replied
    Blade, is this Scout thing something that the editor uses? I see that it extends from Pawn. Don't really see how it fits into the process. We are talking about the editor having problems generating navmeshes.

    Or do you mean something else than the UnrealScript class when you say "Scout"?

    Leave a comment:


  • replied
    Might want to have a look at the Scout classes in November versus December, I think there were some changes made to the default Scout setup

    Leave a comment:


  • replied
    Originally posted by Hellclown View Post
    might want to check that you have the debug boxes checked within the pylon settings, and that you have them set to snap to grid in the editor. Not sure if that will help with you issues, if it doesn't you might want to check out these pages: http://udn.epicgames.com/Three/Navig...Reference.html
    http://udn.epicgames.com/Three/Using...ionMeshes.html
    http://udn.epicgames.com/Three/NavMe...lCreation.html
    http://udn.epicgames.com/Three/Navig...Debugging.html
    Well the case of most people here that isnt the problem at all. Since in my case the exact same map used in November works without a hitch. So it's definetly a bug.

    Leave a comment:


  • replied
    might want to check that you have the debug boxes checked within the pylon settings, and that you have them set to snap to grid in the editor. Not sure if that will help with you issues, if it doesn't you might want to check out these pages: http://udn.epicgames.com/Three/Navig...Reference.html
    http://udn.epicgames.com/Three/Using...ionMeshes.html
    http://udn.epicgames.com/Three/NavMe...lCreation.html
    http://udn.epicgames.com/Three/Navig...Debugging.html

    Leave a comment:


  • replied
    There really is some problem with this in december. If you check the logs it says:
    Code:
    WARNING! Could not align pylon Pylon_1 onto grid!  It may be out of phase with the mesh, and fail to link with adjacent pylons.
    Which you normally get when the pylon is too far above or below the ground. But no matter how I tweak the location of the pylon it gives the same error.
    Sounds like an easy fix for Epic.

    Leave a comment:


  • replied
    I confirm the same problems

    Leave a comment:

Working...
X