Announcement

Collapse
No announcement yet.

Dynamic Shadows through Statics

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I didn't say to add more lights than necessary I said for him to switch to dynamic light instead of static because static ones have no effect of dynamic shadows. I know the skylight is from when UT3 first came out he doesn't have to use the skylight it is just a suggestion to see how it looks I know there are other ways of doing this but it doesn't really matter I had these problems a long time ago all I used were instead of static lights I used movable lights and the problems went away.

    Leave a comment:


  • replied
    Originally posted by pulse0o0 View Post
    You can't stop the dynamic shadows from going through static meshes sorry about that but from my experience in multiple engines all of them did the same thing you just have to use dynamic lights everywhere to hide the dynamic shadows that are being a pain and since you can't get lightmass with dynamic shadows you would have to use a skylight with a brightness of say .1 or .2 and make it whatever color you want to make the shadows transparent and for whatever you don't want the skylight to effect just mess around with lighting channels.
    This is bad advice.

    1) Never use skylights, they are a relic from a long time ago that are no longer useful except in very special circumstances, or for things like when a level designer is blocking out their level and they want simple lighting that builds very quickly. Always change the colour of your shadows/ambient light from something other than pure black in the world properties instead.

    2) Hiding shadows you don't want by adding more light sources is just plain silly and is going to cause all manner of problems. Firstly you're not going to actually hide the shadow, since it's probably still going to be drawn, and now you have a whole extra light source to compute that was never needed in the first place.

    Leave a comment:


  • replied
    I guess you have a roof over the house?. The thing with dynamic objects like interpActors is that by default they cast a modulated shadow even if there's light or no light, depending on the type of light of course. If they are hit by a dominant light, they will automatically cast a normal shadow. If they are hit by a static or movable light, they will still cast mod shadows. With movable lights, you can change this to normal shadows if you wanted.

    The only shadows that will not go through all models is "normal" shadows. Modulated shadows will always go through everything.

    The easiest way to deal with this is to disable shadow casting on your dynamic models. Without proper lighting it can look strange for dynamic models casting shadows in an environment where it's not appropriate. This is default behavior.

    The other way is to deal with it through lighting. Light your room with a dynamic light and set up everything correctly to cast normal shadows. This can get very expensive so it might not be worth doing. It's a compromise to deal with dynamic objects and lighting and you have some choices there although they all have their good and bad points.

    Leave a comment:


  • replied
    You can't stop the dynamic shadows from going through static meshes sorry about that but from my experience in multiple engines all of them did the same thing you just have to use dynamic lights everywhere to hide the dynamic shadows that are being a pain and since you can't get lightmass with dynamic shadows you would have to use a skylight with a brightness of say .1 or .2 and make it whatever color you want to make the shadows transparent and for whatever you don't want the skylight to effect just mess around with lighting channels.

    Leave a comment:


  • started a topic Dynamic Shadows through Statics

    Dynamic Shadows through Statics

    Hey,

    I have an interior of a house and the whole house is split up into several static meshes. Basically it's the shell, floor, upstairs floor, walls...etc that are separate objects.

    The problem is that all of the dynamic objects which are upstairs are casting their shadows down to the bottom floor. You can basically see them on the ceiling on the floor below.

    Is there something I can do to stop the dynamic shadows from passing through the static objects and showing up on the bottom of them?

    I've been trying a bunch of different settings on the lights and the objects but to no avail. The main thing I tried is modulate better, but that doesn't help. I've tried dominant directional light and regular directional and that's made no difference. I also have a skylight to brighten up the whole world, but without it, those shadows are just horribly black.

    An oddity I've noticed is that if I disable 'cast static shadows' on the light, the dynamic shadows disappear, but once I build lightmass, they reappear. If I recheck cast static shadows and then uncheck it, they again disappear and it looks ok.

    The next thing I was going to try is setting the dominant light to toggleable because I read that doesn't use lightmass. However, I believe this negates the whole purpose of lightmass.

    Thanks for any advice.
Working...
X