Announcement

Collapse
No announcement yet.

It should work but it not working!?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    It should work but it not working!?

    Now I'm learning about Material editor in UDK and I want to try this material from Documentation page Material example. And this is the network which that page show me http://udn.epicgames.com/Three/rsrc/...ction_full.jpg . But that I create the same network in UDK with November update I get an error! Why?

    #2
    First off, What error are you getting? second, it the vector transform set up correctly? third, post a screen-cap of your setup, we need to take a look at it to find any mistakes.

    Comment


      #3
      Do I need put something into Texture Sample in this network? If I need put something, what I should put there?

      Comment


        #4
        There seems to be one texture sample in there for the reflection map.

        Comment


          #5
          This is my network and error which I get http://img822.imageshack.us/f/captureaf.jpg/. In Texture sample I put rendertexturetarget2d which I can use to make mirror.

          Comment


            #6
            try just a regular texture. using a rendertexturetarget requires a different node layout.

            Comment


              #7
              Originally posted by percydaman View Post
              try just a regular texture. using a rendertexturetarget requires a different node layout.
              Strange I get the same error.

              Comment


                #8
                I'll have to look to be sure, but I would bet there is a cubemap assigned to the TextureSample, which is why the UVs are taking in a 3-component vector. A Reguler texture only needs a 2-component vector for UVs which is why you get that error I believe. You could mask the output of the Transdorm to just R and G with a Component Mask if you need to use a regular texture.

                Comment

                Working...
                X