Announcement

Collapse
No announcement yet.

Problem with Cloth on Rigid Bodies: any fix?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I'll see if I get the same error with an animated mesh instead of a physics body...

    Leave a comment:


  • replied
    Maybe you can't have 2 different types of physics calculated to the one model.

    Leave a comment:


  • replied
    Originally posted by obihb View Post
    Out of curiosity I tried this for myself and it works fine for me. I wonder if it's just how you've got the cloth set up maybe?. Here's what I do.

    In Max (or whatever program) I have a cloth model and add 2 bones, root plus one linked to it. Skin the static verts to root and the rest of them to the other bone. Export. Import as skeletal mesh. In the editor set those verts on the non root bone to be cloth. I've got a bunch of tweak on the cloth for simulation sake but that's not mandatory.

    Place this mesh in the level, check on to enable cloth and sim on startup. Place a rigid body model and attach the cloth to the rigid body. That should do it.
    That is almost exactly what I do, except I don't attach the cloth to a rigid body, the rigid body is the same skeletal mesh as the cloth.

    Leave a comment:


  • replied
    Out of curiosity I tried this for myself and it works fine for me. I wonder if it's just how you've got the cloth set up maybe?. Here's what I do.

    In Max (or whatever program) I have a cloth model and add 2 bones, root plus one linked to it. Skin the static verts to root and the rest of them to the other bone. Export. Import as skeletal mesh. In the editor set those verts on the non root bone to be cloth. I've got a bunch of tweak on the cloth for simulation sake but that's not mandatory.

    Place this mesh in the level, check on to enable cloth and sim on startup. Place a rigid body model and attach the cloth to the rigid body. That should do it.

    Leave a comment:


  • replied
    Originally posted by HavocInferno View Post
    wow! is that a parallax floor material? impressive!
    yes, for more on that see here. Now, back on topic:

    Originally posted by HavocInferno View Post
    idk, but it seems like a part of the cloth thing was fixed to a specific point that is just moving along with the mesh, and is stretching the according cloth point to it...cloth is made with bones, no? have you checked the bone's settings?
    I've tried many different tweaks, including removing the collision body from the physic's body (thus removing the bone) but that does not work, I've tried just about every checkbox combination: still no luck. I've also tried this in the newest version (11-10) as well as an older version (8-10) and still the same. This is not the only asset I have that demonstrates this bug.

    Leave a comment:


  • replied
    wow! is that a parallax floor material? impressive!

    idk, but it seems like a part of the cloth thing was fixed to a specific point that is just moving along with the mesh, and is stretching the according cloth point to it...cloth is made with bones, no? have you checked the bone's settings?

    Leave a comment:


  • started a topic Problem with Cloth on Rigid Bodies: any fix?

    Problem with Cloth on Rigid Bodies: any fix?

    I'm having a bit of trouble getting cloth to work on rigid bodies in the game world. When the rigid body is asleep, the cloth acts mostly fine. If the rigid body is somehow moved or effected, the cloth detaches itself and floats mid-air as if attached to something else. Once the rigid body goes to sleep, the cloth returns to its correct position. It's difficult to explain in words, so here is a video:



    If anyone has encountered this problem and has found a solution, please reply.
    thanks
Working...
X