Announcement

Collapse
No announcement yet.

Dynamic Shadows only casting on objects and vehicles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dynamic Shadows only casting on objects and vehicles

    I have noticed that the dynamic shadows don't cast at all on my first person model but when inside a vehicle it shows on the vehicle just fine yet it first person my gun could still be lit up. Borderlands which used UE3 had dynamic shadows and could cast on the first person mesh so I know it's possible I just need some help on the subject it has been bugging me for a long time now and I can't find anything that helps.

    #2
    Yea I posted the same problem the other day. The only light i can get shadows cast off geometry onto the fp weapon (preshadow?) is from a normal dominant light. Not a moveable dominant light, nor a moveable point light. It's bugging me because I have a pretty sweet lighting config going on otherwise. I've tried everything I can think of and I know UE pretty well.
    If I move the weapon into the world depth priority group it's fine, but that causes a whole other can of worms I don't want to have to deal with unless really really necessary.

    Comment


      #3
      What type of light(s) do you use?

      Comment


        #4
        Any type of dynamic light doesn't seem to work and it just seems strange that they don't cast on FP by default.

        Comment


          #5
          To my knowledge, there's no mesh when in first person mode. Just player's hands which souldn't really cast any shadows. I guess this is why the shadowing is disabled for the first person mode.

          Comment


            #6
            Well the weapon is a skeletal mesh perhaps there is an option in the skeletal mesh editor somewhere I will have to check.

            Comment


              #7
              Originally posted by ThePriest909 View Post
              To my knowledge, there's no mesh when in first person mode. Just player's hands which souldn't really cast any shadows. I guess this is why the shadowing is disabled for the first person mode.
              The problem isn't getting the fp arms and gun to cast their own shadow, its getting them to receive shadow from world geometry in the same manner that the normal domdir gives you.
              It's perfectly acceptable to have arms and weapon self-shadow, there's an ini switch bAllowForegroundSelfShadowing, but thats not what we're talking about here.

              Comment


                #8
                Ahh yes but it seems no one on these forums has the answer unless one of the workers at epic helped with this if they knew why. But it's doubtful.

                Comment


                  #9
                  Originally posted by Jetfire View Post
                  The problem isn't getting the fp arms and gun to cast their own shadow, its getting them to receive shadow from world geometry in the same manner that the normal domdir gives you.
                  It's perfectly acceptable to have arms and weapon self-shadow, there's an ini switch bAllowForegroundSelfShadowing, but thats not what we're talking about here.
                  Well... They should be able of accepting shadows from other objects. At least that's the way it works for me.
                  My guess is that you need to setup your lights the "right" way in order to get the effect you wish for.

                  Comment


                    #10
                    All you said there is 'i'm doing it wrong'. Care to show me a picture with your fp weapon with a shadow cut across it from a static mesh lit by anything other than a dominant light followed by your light settings?

                    Comment


                      #11
                      I didn't went into any details cause I though that some things like vthe "cast Dynamic shadows" under lights properties are meant to be already known. I'm certainly not the "you're doing it wrong" kind of man. All I'm sayng is that if your light source is either static or emissive it ain't gona cast any shadows. The very same thing counts for simple rigged bodies. I hope this helps.

                      Comment


                        #12
                        I do hope Epic recognizes this issue many people are having if it does have something to do with the engine than I am hoping for a fix or some turned on by default that we might be skimming over, I am not asking necessarily this or next release it would just be nice to actually be able to use dynamic lighting without this aggravating issue.

                        Comment


                          #13
                          Originally posted by ThePriest909 View Post
                          I didn't went into any details cause I though that some things like vthe "cast Dynamic shadows" under lights properties are meant to be already known.
                          Yes, the lights are casting dynamic shadows, and the static mesh are in the dynamic channel. Otherwise the shadowing wouldn't be working on the skeletal meshes in the world depth priority group...

                          Originally posted by ThePriest909 View Post
                          If your light source is either static or emissive it ain't gona cast any shadows. The very same thing counts for simple rigged bodies. I hope this helps.
                          Wut?

                          Comment


                            #14
                            Any suggestions, maybe we are doing something wrong here? This would clear up one of the larger problems for development.

                            Comment

                            Working...
                            X