Announcement

Collapse
No announcement yet.

Fuzzy shadow problem with any static mesh

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Fuzzy shadow problem with any static mesh

    Hi there,

    I have a simple question about shadowing. I have exhausted google and forums in an attempt to solve this issue. I have also fiddled with settings everything but to no sucess.

    My problem:




    the parts circled in red show what looks like a fuzzy shadow. in the first picture, shadows are on and you can see the fuzziness on the ground between the characters legs.

    the second picture has shadows on the object turned off but does contain a light in the scene. yet there is still a fuzziness there.

    is this a kind of self shadow? it only pops up with one static mesh is near another. Am i missing something obvious here? i have built lighting on all settings and lightmass.

    any info would be appreciated

    #2
    That's AO, or Ambient Occlusion, you can turn it off in the Postprocess-chain, or under World Properties.

    Comment


      #3
      thanks for the reply. However, with ambient occlusion turned off, i still get the same problem.

      when i move around with my camera, it seems to affect it. and it only appears when its close to another object.

      edit: i thought it might be important to note that this can be seen, in and out of the editor

      Comment


        #4
        Do you have squint mode on? Check the perspective viewport toolbar. Probably not, just a thought.
        Team13

        Comment


          #5
          Na squint mode is not on. Perhaps it has something to do with a draw distance of something?

          Comment


            #6
            Make sure you disable the post process AO and not the lightmass AO. Which in fact should be off by default I think.

            Comment


              #7
              Yeah this isn't shadow so I am not sure why is showing up if you indeed have turned off AO have you turned of Dynamic AO in world settings?

              Comment


                #8
                pasted:
                SSAO Reduction
                By default, UDK has strong Screen Space Ambient Occlusion (SSAO). This is the black halo around everything, and depending on what kind of scene you're doing this can look really good or really bad.

                If you search "console" in the content browser, UTPostProcess_Console Post Process Chain will show up. You may wish to setup your own custom post process chain, but for now, we're going to quickly adjust the default.

                Open UTPostProcess_Console (double click it in content browser), select the AmbientOcclusionEffect and lower the number for the Occlusion Power. The other settings are useful as well, but this is the immediate "tone down that black stuff" answer.

                Comment


                  #9
                  thanks for the replies everyone.

                  Going into UTPostProcess_Console and turning down the occlusion power got rid of the black effect.

                  The first time i went into world properties, I disabled the lightmass AO, thinking that was the only kind of AO there, and not the AO under worldinfo tab.

                  Explains why nothing happened. doh =(

                  Comment


                    #10
                    Hi,

                    The way to turn that off is by doing this:
                    View-->world Properties -->WorldInfo-->Default Post Process Settings---> Uncheck Allow Ambient Occlusion (theremight be 2 boxes so uncheck both of them) .

                    Comment


                      #11
                      I think it is just a graphics card issue because at my class the computers show that effect 100 times worst than what you are experiencing. At home though on my computer I dont have that issue at all.

                      Comment

                      Working...
                      X