Announcement

Collapse
No announcement yet.

UDK crashes when I launch my map.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK crashes when I launch my map.

    Hello,

    When I load my map in UDK, it crashes. This happened to me today all of sudden. I didn't change anything in my packages, nor in my scripts. Last time I opened it it worked fine. I don't get it, I have no idea what the problem is. When I load other maps in UDK it works fine.

    Could it be that my map has simply become corrupt or something? This is a big bummer because I've been working on this map for nine friggin weeks...

    #2
    If corruption is the case, fret not. UDK autosaves.
    Open the autosaves folder and look for the latest one.

    Comment


      #3
      I sure hope that you have been saving iterations of the map along the way, but is there any chance that you accidentally opened it up in a later version of the editor? I supervise a class on this editor and some people seem to upgrade versions at home and use older ones in class OR they click the wrong Editor link in the start menu thinking that it links to the newer one and not the older.

      What I'm trying to get at is that almost all of the crashes I've seen are results of version changes, not corruption...

      Comment


        #4
        No, it's definitely not a different version. I myself am a student with UDK lessons, and our teacher explicitly told us to use the april beta, so that's the one I've always been using.

        As for the autosave, there is none for this particular map. It's been a while since I made any changes to that map, so I guess it just didn't make one.

        Comment


          #5
          It doesn't overwrite autosaves as long as the maps have unique names.

          The autosaves aren't placed along with the maps, but in a folder called autosaves.

          Comment


            #6
            I know, I checked it but it's not there. I might have an older version of the map on the school computer though...

            Comment


              #7
              Also as a side note, Terrain seems to be an issue with some people. I haven't ever had a problem, usually adding more than 5 materials to a terrain will turn it rainbow colored - which can be fixed, but lately it has been causing maps not to load. Did you use terrain in your level? It might be too late to fix now, but at least we can prevent future problems.

              Comment


                #8
                I did have a pretty big terrain, it only had one material though.

                Comment


                  #9
                  Originally posted by Weveran View Post
                  usually adding more than 5 materials to a terrain will turn it rainbow colored - which can be fixed
                  Please, elaborate!

                  Comment


                    #10
                    Rainbow colors on terrain is not bug, its somehow weird way of editor to tell you that terrain has to many textures.

                    Limit for shaders is 17 think, and your terrain exceeded that limit.

                    Some terrain materials are multi texture, they have specular+diffuse+normal. One such terrain material counts as 9+1 when you have 3 different materials blended for eg. grass+sand+mud. So easily 2 "TERRAIN materials" can exceed limit, because they bled 5 materials that each has 3 textures, (add blending masks and you over 17).

                    ps. "terrain material" "material" and "texture" are all different critters.

                    Comment

                    Working...
                    X